Hemi Truck Club banner
3581 - 3600 of 3629 Posts

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,590 · (Edited)
Just a note about using flex joint bellows and the install locations. I used a flex joint bellows assembly in the 2 1/2 hot side Y pipe. I've seen other turbo hot side systems built with a bellows style flex joint. Normally, I use a bellows internal with the wire mesh outer sleeve.

Well, early last week after doing the three 7psi boost test hits. Everything was running good. :smitten:

Started up the 05 to go down to get some stuff from the hardware store. There was an exhaust leak coming from the passenger header area. So, put the 05 back into the garage... :sad:


 

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,591 · (Edited)
Started looking for the exhaust leak and this is what I found. What I didn't realize is the bellows style flex joint expands when under pressure. There's no wire mesh to stop it from expanding. It snapped the pipe off the header just after the weld. The bellows flex joint found the weak spot... To add insult to injury. The stud snapped off the V band...:facepalm:
 

Attachments

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,592 ·
Welded the pipe back on the header and started adding bracing to it. Should be no problem with the header pipe now. Will have to replace the bellows flex with a outer wire mesh style flex joint to stop the Y pipe expanding movement.







 

Attachments

·
Greg
Joined
·
19,974 Posts
Couplers come in many levels of quality. For boost application make sure the coupler states for boost.. I had one it's internals collapsed plugging the pipe.
 

·
Greg
Joined
·
19,974 Posts
Picture..
 

Attachments

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,596 ·
Looking forward to working on the 05's turbo system today. My back has been giving me problems the last couple of days. So had to take it easy. Feeling much better today. Makes you appreciate the simple things like tinkering on the truck. :) Unfortunately, have to catch up on the yard work too... :rolleyes:
 

·
Administrator
Joined
·
17,884 Posts
Good catch. Another thing I am seeing is your welds are too cold your not getting very good penetration. Notice how yours beads are sitting high mounded not smooth to both sides that makes for very weak joints and will break. Just letting you know.
 

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,598 ·
Haven't had problems with the welds except for if I turn it up a little, it blows holes in the tube. Don't have the best mig welder but, it gets the job done.
 

·
Stu
Joined
·
21,241 Posts
Discussion Starter · #3,599 ·
The 05 is up and running. She's running better. Must have been weak coil packs. Not as sluggish now at the lower rpm. Even the idle sounds meaner. :thumb:
 
3581 - 3600 of 3629 Posts
Top