Hemi Truck Club banner

1 - 13 of 13 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Got my O2 sim installed and it's for real. I take my time with wiring projects to get them right and make them look clean so it probably took longer than most. I will say that finding the right wires was a pita. This attached may help future installers as their instructions are generic. The way mfgr's hide all the wiring nowadays it was difficult to find a keyed +12v. I stared at the fuse box for a while trying to figure out how to tap into an unused slot but it was more work than it was worth.
 

·
Registered
Joined
·
40,856 Posts
Good info! Thanks for sharing this with our members
 

·
Registered
Joined
·
118 Posts
i'm curious to see if this is a permanent solution, i was told by someone who makes the 02 sims for older dodges that newer dodges, especially the hemi, will throw a code after it realizes that the 02 sim is there. the pcm knows that the sim is there because it shows a constant voltage is what i heard. the 02 sensors in the newer vehicles go through a test sequence and e sims don't allow that test to happen. so after a while, from what i was told, the CEL will be on.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
Watching the sim thru diag software it does not show constant voltage and IIRC varies w/ throttle response. It does however show Closed Loop Mode first thing when starting up cold, so it never enters Open loop until warmed up.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
Well this last week I threw another P0430 code, which I thought was pretty impossible with the O2 sim installed. So far they've only returned 1 email and it was pretty thin. We'll see.
 

·
Registered
Joined
·
118 Posts
i guess this confirms what i heard. electrical sims won't work in a hemi. only mechanical sims or custom tunes for us
 

·
Registered
Joined
·
118 Posts
i heard from a reliable source it's not possible. i investigated this option a while back because i was worried when i do my header install i will get a CEL and all my research said these electric sims won't work on a newer pcm. they don't allow the OBD2 test to work on either pre start up or post start up(i can't remember which one it was)
 

·
Registered
Joined
·
173 Posts
I've had mechanical sims for a couple years now and don't have any problems.
 

·
Registered
Joined
·
173 Posts
Steel wool? I'm using two anti foulers stacked up on each rear sensor. Tried one on each side first and still would throw an occasional code so I put on another one.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #12
Well O2simulator.com hasn't returned emails, even when I responded with the answers to their initial question for a quick test. The red flag before I bought was the lack of contact info or phone number. It's just a gmail address. I guess I'll just chock this up to a learning experience and a warning to others. All I can take from this is that they have no desire to stand behind or troubleshoot problems with their product. Odd thing is the code shifted from bank 1 to bank 2 after the install.
 

·
Registered
Joined
·
4,307 Posts
do the plug fouler mod with steel wool...i have had no cat codes in years running this way...





 
1 - 13 of 13 Posts
Top