Hemi Truck Club banner
Status
Not open for further replies.
441 - 460 of 563 Posts

·
Registered
Joined
·
793 Posts

·
Registered
Joined
·
40,856 Posts
Originally posted by SILVERBEAST:
Try re-setting your PCM.
How do i do that?
Fuse #19 for the '03 models, for the '04/'05 models it's fuse #23. Pull the fuse. Get behind the wheel and put the seat belt on. Turn the key to on (but do not start it), and wait for a series of chimes to stop. Turn the key off, plug the fuse back in... turn the key on and wait for all chimes to stop again. The PCM has been re-set!
 

·
Registered
Joined
·
793 Posts
ok ill try that thank you
 

·
Registered
Joined
·
793 Posts
ok i did both of those ways and it still jumping the rpms around
 

·
Registered
Joined
·
34 Posts
Hi everybody! Heard about this site on a couple other forums, and thought I would join because, well, I just bought a hemi, lol. 2005 solar yellow quad cab 4x4 Big hron edition. Looking forward to chatting with all of you!
 
G

·
SILVERBEAST, I am sorry man, but it sounds like you need to either get a new sensor or a new set of gauges.

obnxs! Glad you signed up!
 

·
Board of Directors
Joined
·
25,097 Posts
obnxs
 

·
Registered
Joined
·
793 Posts
ok it seems pretty simple to do myself its on top of the pumkin and pretty dirty. thank you
 

·
Registered
Joined
·
40,856 Posts
Welcome aboard obnxs - we're glad you joined us!
 

·
Registered
Joined
·
2,491 Posts
obnxs!
 

·
Board of Directors (Jay)
Joined
·
43,454 Posts
back!
 

·
Registered
Joined
·
5 Posts
hemi noises... the ticking is normal but when i am in the throttle it makes a whistle dieseling sound.. almost sounds like water in the exhaust or something... and check engine light has come on 2 times with only 3000 miles on it... it is an o7.. someone please help.. people at dealer think i am stupid....
 
441 - 460 of 563 Posts
Status
Not open for further replies.
Top