Hemi Truck Club banner

1 - 20 of 20 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
just put on new cai now under load truck will stall out and have to stop, turn key off, then restart. what the heck, any help would be good.

possible damaged ait sensor? thanks
 
G

·
... Beats me, never heard of any problems...my CAI works good, basically it's just a conduit for air to the engine, right?
 

·
Premium Member
Joined
·
13,314 Posts
ap


temp sensor in CAI might be shot. someone will be along shortly and assit you but that might be it.
i think i have seen others haveing this same problem.
someone will help you soon.
 

·
Registered
Joined
·
7,098 Posts
What brand name CAI did you purchase and where did you purchase it from?

Interesting screen name...

Pup
 

·
Premium Member
Joined
·
13,314 Posts
quote:Originally posted by HEMI-PUP:
What brand name CAI did you purchase and where did you purchase it from?

Interesting screen name...

Pup
hummm just noticed that,,,,good catch wonder whats up?
 

·
Registered
Joined
·
1,911 Posts
Left you a couple replies on this issue in the Cold Air Intake forum.
 

·
Registered
Joined
·
12,588 Posts
do the key trick. Hold trip reset in turn key in on position and release trip button. You should get a code on the odometer area.
 

·
Registered
Joined
·
40,856 Posts
Welcome to HTC "moparh8tr" - hope you get that CAI issue resolved soon! Either your AIT sensor took a hit, or perhaps your negative terminal isn't connected tightly


Also - an explanation of your handle would be a good idea... thanks!
 

·
Registered
Joined
·
40,856 Posts
But that still makes no sense at all...
 

·
Registered
Joined
·
4,767 Posts
sorry to here about your problem i have never heard of this! did the check engine light come on?
 

·
Premium Member
Joined
·
13,314 Posts
quote:Originally posted by MrHemi:
But that still makes no sense at all...
yeah what he said (insert dunno smiley here)
 

·
Registered
Joined
·
1,893 Posts
like what the others said and good luck also post when you find out what the problem was.
 

·
Registered
Joined
·
3,308 Posts
 

·
Board of Directors (Jay)
Joined
·
43,454 Posts
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #20 ·
Thanks for all the replies, the mopar hater thing, this is the 3rd ram i've had, my other 2 were lifted 99 318 sc. I rode it too hard broke often. Any way. Got to love the mopar.
Name is oxymoron or something. Going to try the trip key trick see if any codes. Thanx everyone
 
1 - 20 of 20 Posts
Top