Hemi Truck Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,432 Posts
Discussion Starter #1
have a little problem.the headlights on my sons car the 07 charger/6.1 have a headlight dimming problem at a stop alt.is chargin,new battery the dealer said it needed? but it still does it.anybody have any ideas.everything is still under warrenty except the battery.
 

·
Registered
Joined
·
3,432 Posts
Discussion Starter #2
have a little problem.the headlights on my sons car the 07 charger/6.1 have a headlight dimming problem at a stop alt.is chargin,new battery the dealer said it needed? but it still does it.anybody have any ideas.everything is still under warrenty except the battery.
 

Attachments

·
Board of Directors
Joined
·
25,097 Posts
I found a discussion about this issue:

http://www.chargerforums.com/f...wthread.php?t=121149

These guys are saying that the battery is in the trunk and the long battery cables are to blame. Also some say the battery may not be stout enough. I didn't know SRTs had a rear-mounted battery. Maybe run a second battery cable (or a bigger one) and see if anything changes?
 

·
Registered
Joined
·
3,432 Posts
Discussion Starter #4
thanks
Originally posted by HemiByrd:
I found a discussion about this issue:

http://www.chargerforums.com/f...wthread.php?t=121149

These guys are saying that the battery is in the trunk and the long battery cables are to blame. Also some say the battery may not be stout enough. I didn't know SRTs had a rear-mounted battery. Maybe run a second battery cable (or a bigger one) and see if anything changes?
 

·
Administrator
Joined
·
17,780 Posts
Check the dash cluster all the control circuits for lights tie into it and they are known for causing issues even if the alt and everything else is working fine I am an ASE certified master tech and have changed 3 out so far it is hard to diagnose alot of amperage measuring on input and output wires in light circuit going to it but you can find it it is because of the lamp out indicator in order for the car to know a light is out it has to monitored this is why the lights tie into it the cluster has to be programmed by a chrysler scanner the damn things a comp module

Whatever you do if you diag it down to the cluster don't I repeat don't buy a used one they are flashed by vin and very likely the used one will have same issue
 

·
Registered
Joined
·
5,494 Posts
Apparently all the LXs have trunk-mounted batteries. Part of their Mercedes heritage, probably. Our C is going on six years old, OEM battery, 66K miles. Since the battery didn't cure it, you may want to have the alternator tested.
 

·
Administrator
Joined
·
17,780 Posts
Trust me unless your car has been submerged under water to where the batt cable got water in both ends it is no the issues I have changed one batt cable in 10yrs and it was cut only reason I changed the issue is elsewhere check that cluster bet u find an issue
 
1 - 7 of 7 Posts
Top