Hemi Truck Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter · #1 ·
It's been a long time since I've been on here. My '08 has been in the shop 3 times in past 18 months totaling up to 7 months of waiting. Currently, it's on a 2 month vacation with a transfer case issue. First, case got destroyed... something gave up on inside and got replaced for free (thank you lifetime power train warranty), but when I picked it up and test drove it, the 4wd dummy light and service 4wd light blipped on and off with a beep from the dash came on. The lights don't stay on, but every (hard) acceleration it does this... or on a hill.

My truck is being neglected by the stealership and I'm getting frustrated with them.

PLEASE HELP!!!
 

·
Administrator
Joined
·
17,916 Posts
So you have a rebuilt t case and on hard accel you have issues with it. When the old case let go did it explode and take out wires also?
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #3 ·
It didn't explode... just the internals busted. While driving in 2H... it slammed into 4L at a stop light. Right before it slammed, the lights did the same thing... service 4wd and 4wd blinked and beeped.
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #5 ·
That's a good question... I believe they changed the actuator and the case. They first thought it was the motor, but found out it was internal. I literally only drove it for 2 mins before we parked it with this issue.
 

·
Registered
Joined
·
431 Posts
Discussion Starter · #7 ·
I was curious if the power supply to the case would be faulty... but idk anything about that...lol
 
1 - 7 of 7 Posts
Top