Hemi Truck Club banner
1 - 14 of 14 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I was sent here from the HP Tuners forum. I am swapping a 5.7L Hemi into my dads truck, His 3.7L blew a head gasket at 300K.

Truck was a 2004 Dodge Ram 1500 3.7L with the NV3500
Donor Truck was a 2004 Dodge Ram 2500 Auto

Goal: 2004 Dodge Ram 5.7L with the NV3500

So far, The motor with the proper mounts, and the 5.7L Hemi Clutch and Flywheel kit everything went together and in the truck smooth. I got a TPS Box, Cable and the portion of the wiring harness for the box this truck was missing from another 2004 5.7L donor truck, added that portion of wires to my PCM plugs. Got that far put it back together 100%. Fired right up, checked for issues and took it for a test drive, Swap done so I thought. Loaded up HP Tuners to change all the communication settings to match the 3.7L computer, and change the transmission to manual. I got no crank/start. Turned it back to auto and she starts but it seems it idle different rather the clutch is in or out. Then I get out and notice the brake lights are on all the time??? That is my issue, If i could get it to run in manual mode where the PRND21 will go off the gauge cluster,, and not have the brake lights lit all the time Its done. We even got headers, and a exhaust on here.

Any help or light on the issue is appreciated, Thanks in advanced, I have been trying to figure this out for a week now. I am at a loss, I dont want to redo the whole brake wiring to make this work, He uses the cruise control unfortunately.

Edit: When wiring in the TPS Box the hemi had the 4 PCM plugs, and a big black plug, and a big grey plug. The 3.7L only had 3 PCM plugs (obviously minus the auto transmission) and one big black plug then a smaller 2 way plug. The two way is now wired into the grey plug along with the TPS Box wires that I got from the Donor truck. Everything was de-pinned from the donor harness and pinned back into my harness, No splices, Id like it looking factory when I am done.
 

· Administrator
Joined
·
18,176 Posts
Setting the pcm to manual I believe results in issues. I use HP tuners and I had to leave auto selected and just deal with the guage cluster having rings around all positions. What I did have to do was go in and set neutral and park rev limiters to my desired red line so I could actually drive it.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I managed to get all these issues solved finally. Brake lights were an issue because I had some PCM Brake signal pins in the wrong place, The 3.7l used some of those wires for the S/C. Repinned those and had to run an ignition wire to one of the pins on the brake switch, That solved my issue for the brakes, The manual no start was solved as well. The PCM was ignoring the T41 circuit even though it was acting right when I pushed the clutch in. I ground the starter relay before the PCM and it solved the issue. Its in manual mode and runs and the PRND21 turned off.

Only issue now is the PCM vin doesnt match everything else so I got ABS, and BRAKE light on the dash. Ill probably tackle this another time. So far the NV3500 is doing fine.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #8 · (Edited)
Okay, a new problem arose, Road around in the truck for about 30 minutes and everything seemed good, went for a drive again today and the truck went in limp mode. P0888 and another shift solenoid code. This makes no sense seeming its in manual. Any light on the issue? is there a way to disable those codes or maybe wipe the entire controller from the PCM, I removed it from the tune but that just stops it from writing to the PCM.

Seems to go into limp mode at 40MPH

Also the red lighting bolt with reverse parentheses is flashing when it goes into limp mode. not sure if thats normal or not for limp mode

Update: That is solved, had to disable all the VSS and PRNDL settings in HP Tuners, This truck is so much faster. why they ever put a tiny little 3.7l V6 is beyond me. This is the way it should have been from the factory. Im sure the hemi probably gets just as good MPG.
 

· Registered
2004 GTX
Joined
·
79 Posts
John glad to see you made it over to here, Go in to Engine Diag disable code P0700..it'll pop up once in a while.

the Getrag 238 is stronger trans , might want to look for one of those, if the NV takes a crap, besides the drive shaft it's a straight replacement.

The Nv3500 will last longer then most people think, just watch that 2nd to 3rd "speed shifting" , we have a local guy here with an 03 QC 4x2 that ric3xrt did the swap to about 5 years ago now. (that was a Real pig V6 5sp qc4x2) truck runs a mild eagle head 5.7, 6.1cam LX intake, with 05 ECU swap, he brought it by and we "freshened up" the trans about 5 months ago, needed input bearing , we replaced all bearings , gears looked good.

My youngest kid had an 95slt ram 5.2 5 speed had the NV3500HD, the one with the horrible ratio spread between 2 and 3rd gear, swapped it out for the std ratio NV3500 it lasted about 3 years behind a 400hp 5.2 , my kid drove it more on the Mature side then most people, but it did see it's fair share of track use, always street tires, dropped the 3rd gear shift fork a few times after he bought the truck... in-till he learned to shift .... blew the 9.25 twice 1st was Ma Mopar's fault, 2nd was his ...... but that NV lasted till the 440/T56 swap.

It won't take any 4k rpm clutch drops with 29X10.50 slicks and clatracs/single leaf rear set up.
 

· Registered
2004 GTX
Joined
·
79 Posts
I'll add this if anyone comes by in the future, you can run the 5.7 Hemi on the 4.7 ECU , lots of the tables need to be changed over.
 
1 - 14 of 14 Posts
Top