New to me work truck... - Hemi Truck Club
 
Go Back   Hemi Truck Club > State Chapters of HTC.com > Florida Chapter

Reply
 
Thread Tools Display Modes
 
Old 12-20-2013, 09:29 PM   #1
Senior Member
 
FASTHEMIRAM05's Avatar
 
Join Date: Oct 2009
Location: Orlando, FL
Posts: 2,355
New to me work truck...

I was putting too many miles on the Ram so I went and purchased a good used work vehicle.

2004 Explorer with 95k for 4300.00 +++
They were askin 5904+++ but I knocked them down a bit.
Attached Images
File Type: jpg IMG_20131220_205821.jpg (50.8 KB, 3 views)

__________________
Modern Performance Engineering
Had 2002 4.7 RCSB 14.2
Had 2011 RCSB 12.41
Had 2012 RCSB 13.99
Had 2016 QCSB 13.0
2011 Drag Truck....

FASTHEMIRAM05 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-20-2013, 10:33 PM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,207
Garage
Good truck check balljoints sway bar links and thermostat housing assembly all problematic on them other than that decent ride
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 12-21-2013, 05:54 AM   #3
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,280
Garage
Make sure it doesn't have Firestone tires................
Ghost03hemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-21-2013, 04:37 PM   #4
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,174
__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 12-21-2013, 05:18 PM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,207
Garage
Tires were not te issue they just assumed the responsibility

Ford for some dumb reason had a tire pressure card saying 35 rear 25 front so basically after a week or two especially on cool weather when nobody checks there air pressure it was low causing countless blowouts as rollovers

First issue fords card
Second issue uninformed/maint neglecting drivers
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 12-21-2013, 05:22 PM   #6
Board of Directors-Bill
 
arocketman's Avatar
 
Join Date: Aug 2007
Location: Space Coast, FL/Eastern Shore, Va
Posts: 12,477
Garage
Nice '04 Exploder.
__________________
05 QC
BLUE MAX
"Slightly Tweaked"
Just [email protected]




arocketman is offline   Reply With Quote
Old 12-22-2013, 06:55 PM   #7
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,280
Garage
Are you still keeping your truck Josh?
Ghost03hemi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 07:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.