pass window not working - Hemi Truck Club
 
Go Back   Hemi Truck Club > General Maintenance | Owner Info > Interior and Exterior Detailing

Reply
 
Thread Tools Display Modes
 
Old 03-14-2008, 07:04 PM   #1
Senior Member
 
nopeitsherhemi's Avatar
 
Join Date: Jul 2005
Location: Kalliesworld, Indiana
Posts: 13,314
Garage
pass window not working

Passenger side window switch is not working up or down.

Window works fine from drivers side.

Going to do some reading here tonight and see if I can find anything about this.

Like is there a fuse just for that switch?

I plan on taking the door panel off Sunday during the race and see if maybe it just came unplugged.

I am guessing the switch is just bad.

Just seems odd that that it won’t work up or down that is why I am suspecting a relay or fuse.

On my Chevy I had one that worked going up but not going down.

Any thoughts?
Thanks

nopeitsherhemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-14-2008, 11:26 PM   #2
Senior Member
 
zwa21's Avatar
 
Join Date: May 2007
Location: Perry, Oklahoma
Posts: 6,606
pass window not working

Mine does that. Sometimes. I have no idea. Asked dealer once about it. They said it can get dirt in there and not work. WTF. My truck is cleaner than what they have on the lot. Guess they thought I had no brain. I think it bad connection, I'll just work it back and forth or press down on it and it'll start working fine.
zwa21 is offline   Reply With Quote
Old 03-15-2008, 06:21 AM   #3
Senior Member
 
nopeitsherhemi's Avatar
 
Join Date: Jul 2005
Location: Kalliesworld, Indiana
Posts: 13,314
Garage
pass window not working

thanks, sounds like a possible solution, i try to keep the truck clean but with a 6yr old and hauling firewood and taking it to the woods to cut firewood then there is her Master gardening she does all over the place and the load after load after load of mulch she hauls ...........hummmm wonder how it could ever get dirty?

i will take door panel of during race and take switch out to clean/check tomorrow.
nopeitsherhemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2008, 11:21 AM   #4
Senior Member
 
zwa21's Avatar
 
Join Date: May 2007
Location: Perry, Oklahoma
Posts: 6,606
pass window not working

Post your findings. I would like to know if it something I can get fixed. It can be a hassle sometimes.
zwa21 is offline   Reply With Quote
Old 03-15-2008, 12:46 PM   #5
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
pass window not working

Quote:
quote:Mine does that. Sometimes
Same here. Works when it wants to. Sort of like wife.
Superjay is offline   Reply With Quote
Old 03-15-2008, 01:55 PM   #6
Senior Member
 
zwa21's Avatar
 
Join Date: May 2007
Location: Perry, Oklahoma
Posts: 6,606
pass window not working

Quote:
quote: Same here. Works when it wants to. Sort of like wife.
I said work it back and forth, press it down a little. Maybe get rough with it.
zwa21 is offline   Reply With Quote
Old 03-15-2008, 04:19 PM   #7
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
pass window not working

Quote:
quote:Maybe get rough with it.
Oh yeah, baby.
Superjay is offline   Reply With Quote
Old 03-15-2008, 05:52 PM   #8
Silver Surfer
Guest
 
Posts: n/a
pass window not working

sometime a new switch take care of the problem
  Reply With Quote
Old 03-15-2008, 08:12 PM   #9
Senior Member
 
nopeitsherhemi's Avatar
 
Join Date: Jul 2005
Location: Kalliesworld, Indiana
Posts: 13,314
Garage
pass window not working

fiddled with it and she started working again

did not even get the chance to take door panel off..
nopeitsherhemi is offline   Reply With Quote
Old 03-15-2008, 10:33 PM   #10
Senior Member
 
mudchucker's Avatar
 
Join Date: Oct 2007
Location: Alberta Canada
Posts: 1,693
pass window not working

Had the same problem with my 98 2500 CTD PS window,.. It turned out to be a tiny rub through where the wire go through the door and down to the plug. I only found it because it sparked a bit when I messed with the wires,.. but it wasn't enough to blow a fuse.
mudchucker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.