Heated Seats - Hemi Truck Club
 
Go Back   Hemi Truck Club > General Maintenance | Owner Info > Interior and Exterior Detailing

Reply
 
Thread Tools Display Modes
 
Old 12-16-2011, 11:23 PM   #1
Junior Member
 
telephoneted's Avatar
 
Join Date: May 2009
Location: Macduff, Scotland
Posts: 20
Hi,
Both my front heated seats have decided to stop working, just as the weather is turning cold!. I'm wondering if any members know of any common faults that could cause this before I go pulling my Ram apart.
Checked the fuse, etc and it is good, just found it strange that they both failed together.

__________________
04 Quad cab Hemi Ram 1500. Gibson exhaust, Superchipped, cold Air intake, front and rear TV screens, digital TV, DVD and PS2 fitted.
telephoneted is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-16-2011, 11:23 PM   #2
Junior Member
 
telephoneted's Avatar
 
Join Date: May 2009
Location: Macduff, Scotland
Posts: 20
Hi,
Both my front heated seats have decided to stop working, just as the weather is turning cold!. I'm wondering if any members know of any common faults that could cause this before I go pulling my Ram apart.
Checked the fuse, etc and it is good, just found it strange that they both failed together.
__________________
04 Quad cab Hemi Ram 1500. Gibson exhaust, Superchipped, cold Air intake, front and rear TV screens, digital TV, DVD and PS2 fitted.
telephoneted is offline   Reply With Quote
Old 12-17-2011, 02:22 AM   #3
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
That would've been my first guess (fuse). Since both aren't working it can't be the switch... so not sure
__________________
2003 Ram 5.7 HEMI RC 2WD - Supercharged. 520 HP, 14 mpg... SOLD
2006 SRT8 GC AWD 6.1 HEMI - 420 HP, 16 mpg... SOLD
2005 Ram 5.7 HEMI QC 4X4 - bone stock work truck... SOLD
2009 Ram 5.7 HEMI QC 4X4 Laramie - bone stock for now

MrHemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2011, 05:43 PM   #4
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
My front seats have separate switches. Have you made sure that power is coming out of the fuse block? Sounds like a wire went dead to me.
__________________

RANCHER is offline   Reply With Quote
Old 12-17-2011, 10:41 PM   #5
Junior Member
 
telephoneted's Avatar
 
Join Date: May 2009
Location: Macduff, Scotland
Posts: 20
Showing power out of the fuse block so it looks like I'll have to dig deeper. Thanks to you guys for the quick answers
__________________
04 Quad cab Hemi Ram 1500. Gibson exhaust, Superchipped, cold Air intake, front and rear TV screens, digital TV, DVD and PS2 fitted.
telephoneted is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.