AC blower motor - Hemi Truck Club
 
Go Back   Hemi Truck Club > General Maintenance | Owner Info > Interior and Exterior Detailing

Reply
 
Thread Tools Display Modes
 
Old 08-04-2010, 04:46 AM   #1
Junior Member
 
Join Date: Dec 2009
Location: St. Louis
Posts: 12
AC blower motor

I have a new issue. My blower motor for the A\C - heater is acting up. I have an 03 regular cab short. Before now once in a while while driving I would hit a bump and the blower would stop. I could reach under the column and wiggle the wires leading into it and the blower would come back on. Or if I adjusted the wheel up and down it would come back as well. Now all that being said it quit all together recently. Does anyone have any idea which wire would be in the column that would have anything to do with the blower motor? Or any idea what the issue may be as a whole? Thanks guys.
Miki

stlmikie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-04-2010, 04:20 PM   #2
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
Quote:
Originally posted by stlmikie:
I have a new issue. My blower motor for the A\C - heater is acting up. I have an 03 regular cab short. Before now once in a while while driving I would hit a bump and the blower would stop. I could reach under the column and wiggle the wires leading into it and the blower would come back on. Or if I adjusted the wheel up and down it would come back as well. Now all that being said it quit all together recently. Does anyone have any idea which wire would be in the column that would have anything to do with the blower motor? Or any idea what the issue may be as a whole? Thanks guys.
Miki

My blower motor problem was due to a bad ignition switch , sent you a PM on what to check
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Old 08-15-2010, 03:27 AM   #3
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
Any luck finding the problem ?
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2010, 07:33 AM   #4
Senior Member
 
mindy's hemi "Satch"'s Avatar
 
Join Date: Jun 2004
Location: Deltona, Florida
Posts: 2,171
Just got done replacing my BURNT ignition switch module and the connector assembly I had the same symptoms. Picture here if it makes it.....
Attached Images
File Type: jpg burnt.JPG (162.6 KB, 116 views)
__________________
mindy's hemi "Satch" is offline   Reply With Quote
Old 08-15-2010, 03:51 PM   #5
Junior Member
 
Join Date: Dec 2009
Location: St. Louis
Posts: 12
Yeah 5speed. That was it. Easy fix once you diagnosed it. Just in time too. It has been really hot here. Thanks a ton. If you were here now I would kiss your face.
stlmikie is offline   Reply With Quote
Old 08-15-2010, 04:31 PM   #6
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
Quote:
Originally posted by mindy's hemi "Satch":
Just got done replacing my BURNT ignition switch module and the connector assembly I had the same symptoms. Picture here if it makes it.....
Mine had a similar look to it before I replaced it
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Old 08-15-2010, 04:33 PM   #7
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
Quote:
Originally posted by stlmikie:
Yeah 5speed. That was it. Easy fix once you diagnosed it. Just in time too. It has been really hot here. Thanks a ton. If you were here now I would kiss your face.
Glad I could help ..we have a stand in double for kisses his name is Superjay he should be along shortly
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Old 08-15-2010, 07:44 PM   #8
Member
 
tazassape's Avatar
 
Join Date: Jun 2005
Location: Lewisburg La.
Posts: 60
Quote:
Originally posted by mindy's hemi "Satch":
Just got done replacing my BURNT ignition switch module and the connector assembly I had the same symptoms. Picture here if it makes it.....
My A/C is doing the same thing. Where is this culprit? How does one trouble shoot this? Thanks
__________________
2011 4X4 2500HD HEMI
tazassape is offline   Reply With Quote
Old 08-16-2010, 05:07 PM   #9
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
If there are over heating marks on the plug take the two plastic half's of the steering column where the key goes in off and check your ignition switch for overheating as in Satch's pic . There are three snaps down each side of the switch it comes apart in two pieces its easy to see if the contactor's are fried
Attached Images
File Type: png Picture_1.png (41.6 KB, 103 views)
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Old 08-16-2010, 07:46 PM   #10
Member
 
tazassape's Avatar
 
Join Date: Jun 2005
Location: Lewisburg La.
Posts: 60
Thanks 5SpeedHemi I'll check it out in the morning. I knew I'd get the solution here.
__________________
2011 4X4 2500HD HEMI
tazassape is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.