Oil Pressure Sensor - Error Code -P0520 - Need Help! - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > 4th Generation Ram | 2009 - Present

Reply
 
Thread Tools Display Modes
 
Old 07-01-2015, 08:53 AM   #1
Junior Member
 
Join Date: Jul 2015
Location: East Stroudsburg
Posts: 3
Oil Pressure Sensor - Error Code -P0520 - Need Help!

Hey all ... I am new to this board. Nice to join you.

Last Friday I had a local garage install an Oil Pressure Sensor in my 2011 Ram 1500 Hemi. The error code was reset before I left the garage and a few days later the engine light came back on and is throwing the same error code again (-P0520) - The truck appears to be running fine and the oil pressure is normal with the exception of no eco boost when the error is active and no remote start.

My questions .... Is there a timeframe where the system needs to learn the new part is installed?

If not, what would cause the truck to throw the exact same code after the new part is installed?

Any advice would be greatly appreciated. Thanks

trumpdaddy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2015, 11:02 AM   #2
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,174
Thumbs up





__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 07-01-2015, 04:07 PM   #3
Queen Kima - Whemi BOD
 
Mrs.Studmuffin's Avatar
 
Join Date: Sep 2005
Location: Denison, TX
Posts: 10,245
__________________
.
Not everyone can be queen.....there has to be someone standing on the curb to wave as I go by.
.

Mrs.Studmuffin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2015, 04:36 PM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,911
Garage
New sensor failure, more common these days then we would like to believe. Electrical plug to the sensor not installed properly. Damaged sensor wire.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 07-01-2015, 10:38 PM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,198
Garage
This could be a bad sensor or wire issue. Bring it back and have inspected.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 07-11-2015, 03:49 PM   #6
Gary
 
leadfoot's Avatar
 
Join Date: Jun 2007
Location: Staten Island, NY
Posts: 904
Make sure they changed it. On my 2003 I cleaned mine out and it worked again for a while . Mine went bad on my 2013 with less than 500 miles.
__________________
Old ride
03 ram quad cab hemi

New ride
2013 Ram Crew Cab Sport
No Mods
leadfoot is offline   Reply With Quote
Old 07-11-2015, 09:42 PM   #7
Gold-Member
 
kcd1369's Avatar
 
Join Date: Oct 2004
Location: Brandon, FL
Posts: 4,045
Garage
to HTC
And good luck with the oil sensor.
__________________
05 1500 SLT Quad Black on Black | Pace Setter Long Tubes | Magna Flow Cat Back | Doug's Electric Cutout | Custom Ram Air Hood | Spyder LED Tails | Spec-D Black Projectors W/Halos | Flex-A-Lite E-Fan |Jet 180 Stat | K&N CAI | 20 inch wheels | Comp 268 Cam W/6.1 push rods and springs | Diablo Trinity | Custom Tune by Charged392.





kcd1369 is offline   Reply With Quote
Old 07-12-2015, 10:32 AM   #8
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,630
Garage
__________________

SUPER BEE is offline   Reply With Quote
Reply

Tags
oil pressure sensor


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 04:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.