Coolant Leak - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > 4th Generation Ram | 2009 - Present

Reply
 
Thread Tools Display Modes
 
Old 09-16-2013, 08:15 PM   #1
Junior Member
 
Join Date: Sep 2013
Location: beamsville
Posts: 2
Coolant Leak

Just picked up a 2010 slt with 65k on it 3wks ago... Today there is a puddle of coolant under it! followed the leak from the frame rail to the crank pulley then lost it, water pump housing appears to be dry along with the hole behind the pulley on the pump... cant see any signs what so ever of where it came from (t stat, temp sens, hoses etc) going to get a pressure test done and hopefully find out whats going on. Just came across this site, figured id sign up, say hello and see if anyone has/knows of any problems with the
2010's. Hoping to do a few mods, repairs was not on my list 3wks in tho.

gottobecdn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-16-2013, 08:20 PM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,198
Garage
Welcome to htc

The leak is likely the rubber seal sweating down the timing cover onto the crank area but see what the pressure test shows also the water pump can leak at diff times and may not look like it
__________________
"CMR TUNER" [email protected]6 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-16-2013, 08:58 PM   #3
Gary
 
leadfoot's Avatar
 
Join Date: Jun 2007
Location: Staten Island, NY
Posts: 904
__________________
Old ride
03 ram quad cab hemi

New ride
2013 Ram Crew Cab Sport
No Mods
leadfoot is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-16-2013, 10:21 PM   #4
Senior Member
 
NewBlue's Avatar
 
Join Date: Jan 2011
Location: St. Paul, MN
Posts: 898


And good luck!
__________________
==================================================
New Blue: 2005 1500 4X4 SLT Standard Cab Longbox 5.7 Hemi

MSD 8.5 Super Conductor wires, Airaid CAI, Superchips 3865,
Homebrew E-fan, Custom 2.5" Dual Exhaust with merge Y & 22"
Magnaflow SIDO, Sonnax pressure booster, Stant 190 stat, Fastman TB
---------------------------------------------------------------------------------------
Old Blue: 1988 W100 4X4 Standard Cab Longbox 318 188,000 miles
==================================================
NewBlue is offline   Reply With Quote
Old 09-17-2013, 05:19 AM   #5
Queen Kima - Whemi BOD
 
Mrs.Studmuffin's Avatar
 
Join Date: Sep 2005
Location: Denison, TX
Posts: 10,245
__________________
.
Not everyone can be queen.....there has to be someone standing on the curb to wave as I go by.
.

Mrs.Studmuffin is offline   Reply With Quote
Old 09-17-2013, 05:31 AM   #6
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
Welcome aboard! Hopefully it's just a minor issue - keep us posted.
Your 2010 is the first I've heard of having this problem with the 4th gen trucks...
__________________
2003 Ram 5.7 HEMI RC 2WD - Supercharged. 520 HP, 14 mpg... SOLD
2006 SRT8 GC AWD 6.1 HEMI - 420 HP, 16 mpg... SOLD
2005 Ram 5.7 HEMI QC 4X4 - bone stock work truck... SOLD
2009 Ram 5.7 HEMI QC 4X4 Laramie - bone stock for now

MrHemi is offline   Reply With Quote
Old 09-17-2013, 09:11 AM   #7
Junior Member
 
Join Date: Sep 2013
Location: beamsville
Posts: 2
Thanks for the welcomes!...... Was in a hurry this morning and didn't have the time for a psi test so dropped in some dye and going to check it with the light later today or tomorrow..... Let u know whats going on when i figure it out.
gottobecdn is offline   Reply With Quote
Old 09-17-2013, 10:06 AM   #8
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,915
Garage
Welcome...
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 07:08 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.