Good and Bad News - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Nitrous Oxide Topics

Reply
 
Thread Tools Display Modes
 
Old 08-15-2007, 11:22 AM   #1
Senior Member
 
Join Date: Feb 2007
Location: Central Texas
Posts: 390
Good and Bad News

Good News is everything works great on my kit from nitrous outlet bad news is i want more! lol.... i'ma spray feen now hahaha... i'm gonna do a write up on installing it..because there is a few things that I foudn out while doing this.... anyway 2 thumbs way up and i'm addicted

Tooloe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2007, 12:35 PM   #2
Senior Member
 
CentralTexHemi's Avatar
 
Join Date: Jun 2005
Location: Woodway (Waco), Texas
Posts: 8,246
Good and Bad News

Now if we can just get you to use spell check and quit sniffing the nitrous
CentralTexHemi is offline   Reply With Quote
Old 08-15-2007, 12:53 PM   #3
Senior Member
 
Join Date: Feb 2007
Location: Central Texas
Posts: 390
Good and Bad News

lol it does smell kinda good tho


and let me tell ya..... i'm loveing thaT 75 Shot i wanta do a 100 shot.. but i'm thinking of keeping the 75 in for the street and 100 at the track...... i'v also got a tiny tiny tiny leak some where.hmmmm anyway like i said i'm hooked.. and everythings working great....even the wire i was telling you about that runs across the top of the motor you cna use for a tach signal.....flawless.
Tooloe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-15-2007, 01:51 PM   #4
 
Join Date: Mar 2007
Posts: 211
Good and Bad News

Glad to hear it worked out, you should post some pics of the install
sdogre is offline   Reply With Quote
Old 08-15-2007, 02:34 PM   #5
Senior Member
 
Join Date: Feb 2007
Location: Central Texas
Posts: 390
Good and Bad News

i'll ghet some pictures up asap
Tooloe is offline   Reply With Quote
Old 08-15-2007, 02:40 PM   #6
Senior Member
 
CentralTexHemi's Avatar
 
Join Date: Jun 2005
Location: Woodway (Waco), Texas
Posts: 8,246
Good and Bad News

No pics please, I've seen how dirty that engine bay is-LOL, glad you like it and get that leak fixed and did you guys get the plugs swapped out and how did that go
CentralTexHemi is offline   Reply With Quote
Old 08-15-2007, 02:54 PM   #7
Senior Member
 
Join Date: Feb 2007
Location: Central Texas
Posts: 390
Good and Bad News

haha yeah got the plugs changed yesterday...went very smooth suprizeingly..hey i'll clean it up if i take pictures geez..it's just dirty Horsepower when you open the hood lol.. i can't find the leak.... can't feel it or nothing i'll probally tear the whole little block ting down and by some more fittings that'll let me space the stuff farther apart so i can use and bigger wrench
Tooloe is offline   Reply With Quote
Old 08-15-2007, 09:26 PM   #8
 
Join Date: Jul 2007
Posts: 42
Good and Bad News

Glad to hear you are happy....
n2oHemi is offline   Reply With Quote
Old 08-16-2007, 06:50 AM   #9
Senior Member
 
CRAZYHEMI's Avatar
 
Join Date: Aug 2004
Location: Maryville, TN
Posts: 1,200
Good and Bad News

most likely you have a leak in the connections. Try using more pipe dope or thread tape. Good Luck!
CRAZYHEMI is offline   Reply With Quote
Old 08-16-2007, 05:05 PM   #10
Senior Member
 
Join Date: Feb 2007
Location: Central Texas
Posts: 390
Good and Bad News

found it. it was on the line that connects to the bottle..that run up front..no more leaks
Tooloe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:35 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.