stalling at stop signs - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 05-26-2008, 10:38 PM   #1
 
Join Date: May 2008
Posts: 34
stalling at stop signs

After the truck warms up and is at normal operating temperature, it often, but not always, stalls when I stop. Rpm's stop at about 500 to 600, then drop off below 500 and usually goes back up. Sometimes it drops below 500 and then nose dives to zero. Runs great otherwise. It has 59000 miles and has been doing this for about 6 weeks since we purchased it. Any suggestions will be welcomed.
2004 quadcab, 4x4, auto.

bills2004 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-27-2008, 04:05 AM   #2
Senior Member
 
05whiteHEMI's Avatar
 
Join Date: Jan 2006
Location: Murrieta, California
Posts: 2,708
stalling at stop signs

Any Mods?

Check the normal stuff.

Air cleaner: Dirty?

Throttle body: Dirty?

Spark plugs: How New?
05whiteHEMI is offline   Reply With Quote
Old 05-27-2008, 06:54 AM   #3
Senior Member
 
nopeitsherhemi's Avatar
 
Join Date: Jul 2005
Location: Kalliesworld, Indiana
Posts: 13,314
Garage
stalling at stop signs

don't forget PCV valve,
but yeah clean TB there is a post here someplace on cleaning. it.

run some injector cleaner in the tank, for a few tank fulls.

since you just got it no telling how the last person maintained it, if at all.
nopeitsherhemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-27-2008, 06:58 AM   #4
 
Join Date: Dec 2006
Posts: 195
stalling at stop signs

it could be knacked 02 sensor in exhaust ,, i put mine on back to front and my truck done the same
hemihaggis is offline   Reply With Quote
Old 05-30-2008, 03:07 PM   #5
 
Join Date: May 2008
Posts: 34
stalling at stop signs

Turned hot over the past week and with the A.C. running, it does not stall out. Air cleaner and plugs are fine. Dirty throttle body, could be the answer. Will let you know after cleaning. Thanks for all the suggestions. Oh yes, the injector cleaner (Seafoam) seems to help.
bills2004 is offline   Reply With Quote
Old 06-02-2008, 05:46 PM   #6
Senior Member
 
Join Date: Jan 2008
Location: Columbus, OH
Posts: 158
stalling at stop signs

My 04 did the same thing when i bought it... if you put it in neutral when you stop does it still shut off? thats the only way i was able to drive around is if i threw it out of drive..

Ended up being a messed up tranny... so they said.. the flushed the fluid, changed the filters and reprogrammed the pcm and it runs fine now
Rocky31186 is offline   Reply With Quote
Old 06-02-2008, 10:17 PM   #7
 
Join Date: May 2008
Posts: 34
stalling at stop signs

Putting it into neutral does work, but I really don't understand how the transmission could be a part of the problem. I am going in Fri. to have the throttle body cleaned and the pcv changed. Also checking the plugs and replacing the sensor. I'll have them check the tranny fluid too. I'll post back with the results.
bills2004 is offline   Reply With Quote
Old 06-02-2008, 11:41 PM   #8
Senior Member
 
Solar_Ram's Avatar
 
Join Date: Dec 2005
Location: Hurricaneally, FL
Posts: 3,632
stalling at stop signs

very common problem in a lot of trucks.
go talk to a dealer (or 2 of them) and maybe they can flash you the fix (there was a TSB for this I believe). you may still be under warrantee.
I had it, they fixed it. it still idles low and steady, but not the drop and surge like before.
**when your a/c is on does it still do it!
it is usually not the transmission that does this, it's the computer.
Solar_Ram is offline   Reply With Quote
Old 06-06-2008, 01:05 PM   #9
 
Join Date: Apr 2007
Posts: 131
stalling at stop signs

mine used to do the same, but the resistor in the trans go kit went bad and casued to much line pressure casuing surgin on stops and stalling. basically the trans wasnt able to let go of the gear coming to a stop.
txtruck is offline   Reply With Quote
Old 06-07-2008, 07:28 PM   #10
 
Join Date: May 2008
Posts: 34
stalling at stop signs

Well, got the truck back this afternoon. So far no stalling when I come to a stop, BUT the RPM's still drop and then go back up to normal idle. Had the throttle body cleaned and the sensor replaced. Plugs are still in good shape. Does anyone else have this crazy drop in RPM's then increase to normal??? Maybe this is normal. If not, then I will have them check the transmission go kit resistor when I take it back Monday. They aren't satisfied with it yet either. This is NOT a dealer (don't trust them)just a private garage that has worked on other vehicles for me and proven trustworthy. They aren't Dodge boys, so I need to give them all the hints I can get. Thanks for the help.
bills2004 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 04:38 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.