Possible fuel issue...suggestions? - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 04-23-2012, 04:55 PM   #1
Senior Member
 
HEMIHP's Avatar
 
Join Date: Nov 2007
Location: College Station, Texas
Posts: 238
So my truck sat for just a day and when I came out the next day to crank it up it just started to sputter like it was missing or not getting fuel. It finally started to idle correctly. I went to the gas station to fill up and when left it started fine, however I drove a mile or two and stopped at a light and the truck just completly stalled. I put it in park and started it again and it cranked right up. I have no clue where to really start....fuel filter? throttle body? or something worse? Any leads would greatly be appreciated. Thanks.

__________________
2004 DODGE RAM QUAD CAB
LONESTAR EDITION
MOLTEN RED PEARL
20" FACTORY CHROME RIMS
DEBADGED EXCEPT FOR THE HEMI'S
AT3030 DUMPED
TAYLOR SHORTIES W/ NGK PLUGS
CAI
2/4.5" McGaughys Drop

HEMIHP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-23-2012, 04:55 PM   #2
Senior Member
 
HEMIHP's Avatar
 
Join Date: Nov 2007
Location: College Station, Texas
Posts: 238
So my truck sat for just a day and when I came out the next day to crank it up it just started to sputter like it was missing or not getting fuel. It finally started to idle correctly. I went to the gas station to fill up and when left it started fine, however I drove a mile or two and stopped at a light and the truck just completly stalled. I put it in park and started it again and it cranked right up. I have no clue where to really start....fuel filter? throttle body? or something worse? Any leads would greatly be appreciated. Thanks.
__________________
2004 DODGE RAM QUAD CAB
LONESTAR EDITION
MOLTEN RED PEARL
20" FACTORY CHROME RIMS
DEBADGED EXCEPT FOR THE HEMI'S
AT3030 DUMPED
TAYLOR SHORTIES W/ NGK PLUGS
CAI
2/4.5" McGaughys Drop

HEMIHP is offline   Reply With Quote
Old 04-23-2012, 06:42 PM   #3
Board of Directors
 
HemiByrd's Avatar
 
Join Date: Aug 2005
Location: Draffenville, KY
Posts: 25,097
Garage
Did any trouble codes get set?
__________________
'05 RCSB 1500 SLT 5.7 Hemi Ram - Airaid Long Snorkel UBI CAI - Taylor shorty wires - MSD Coil Packs Magnaflow y-pipe - Flowmaster 50HD - Superchips 3865 - Motive 4.56 gears - Detroit Truetrac - PML differential cover some good Karma 8.87 ET
HemiByrd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-23-2012, 06:51 PM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,089
Garage
Yep, codes would really help. I would start with a PCM reboot.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 04-24-2012, 04:46 PM   #5
Senior Member
 
HEMIHP's Avatar
 
Join Date: Nov 2007
Location: College Station, Texas
Posts: 238
Wish I was a little more mechanically savy but is this something I can do or need to take it to someone with the proper equipment?
__________________
2004 DODGE RAM QUAD CAB
LONESTAR EDITION
MOLTEN RED PEARL
20" FACTORY CHROME RIMS
DEBADGED EXCEPT FOR THE HEMI'S
AT3030 DUMPED
TAYLOR SHORTIES W/ NGK PLUGS
CAI
2/4.5" McGaughys Drop

HEMIHP is offline   Reply With Quote
Old 04-24-2012, 04:48 PM   #6
Senior Member
 
HEMIHP's Avatar
 
Join Date: Nov 2007
Location: College Station, Texas
Posts: 238
So I wish I was a little more savy on how this is done but is this something I can so or do you have to have certain equipment to read the codes?
__________________
2004 DODGE RAM QUAD CAB
LONESTAR EDITION
MOLTEN RED PEARL
20" FACTORY CHROME RIMS
DEBADGED EXCEPT FOR THE HEMI'S
AT3030 DUMPED
TAYLOR SHORTIES W/ NGK PLUGS
CAI
2/4.5" McGaughys Drop

HEMIHP is offline   Reply With Quote
Old 04-24-2012, 05:02 PM   #7
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,089
Garage
Do you know which terminal on your battery is negative? if you do, disconnect the cable. open the door and turn the ignition to the on position and give it a couple of seconds. Turn the ignition off and reconnect the battery. Turn ignition to the on position and count to 10 without pushing the throttle. Turn ignition off and then on and start the engine. Download the service manual and start studying. Good luck..
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 04-24-2012, 09:15 PM   #8
Member
 
2004HEMImarine's Avatar
 
Join Date: Jun 2011
Location: Fort Collins, Colorado
Posts: 54
I've been having a similar issue. Doesn't happen all the time, but its a pain when it does. Fuel pressure is good, throttle body is clean, was told to check my battery posts for excess debris and to look for loose grounds. Hasn't happened again yet, but its got me stymied too.
__________________
Justin

2004 Ram 1500 QC K&N filter, straight pipe (baha), clarion cz300 head unit 2-10" dd subs, 1200 watt dd amp.

2004HEMImarine is offline   Reply With Quote
Old 04-25-2012, 05:55 PM   #9
Senior Member
 
HEMIHP's Avatar
 
Join Date: Nov 2007
Location: College Station, Texas
Posts: 238
Thats the red one or the black? Lucky for me I do. If I can change the plugs on this damn thing which now I understand why the club has SPARK MASTER tabs then it seems like I can handle that. Thanks for the help.

2004HEMImarine: Yeah it only happens evey now and then and I have not been able to really pinpoint anything in particular like bad fuel. Im going to give this a shot and see what happens. I will keep you updated on how I come out.
__________________
2004 DODGE RAM QUAD CAB
LONESTAR EDITION
MOLTEN RED PEARL
20" FACTORY CHROME RIMS
DEBADGED EXCEPT FOR THE HEMI'S
AT3030 DUMPED
TAYLOR SHORTIES W/ NGK PLUGS
CAI
2/4.5" McGaughys Drop

HEMIHP is offline   Reply With Quote
Old 04-25-2012, 07:55 PM   #10
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,404
Garage
Sound like the both of you might have a computer ground strap with a little corrosion or maybe loose. Check all of electrical grounding straps and and ground wires. That's how I fixed the same problem on my truck.
Ghost03hemi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 11:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.