Help! losing coolant - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 01-10-2011, 06:22 AM   #1
Member
 
Godfather_HEMI's Avatar
 
Join Date: Aug 2006
Location: Germany
Posts: 51
Hi everybody.

I have a problem with my 2004 Ram HEMI. My car lose a lot coolant. I made some pictures because I don't know exactly where the problem is.

http://i399.photobucket.com/al...%20HEMI/DSC09484.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09476.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09474.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09472.jpg

The rusty part looks like the servo pump but the servo pump don't need cooling water. Right? Maybe my water pump lose the cooling water? because it sit across the servo pump and the water drop to the servo pump and than to the ground?

Maybe anybody can give me a tip.


PS: Sorry my english is not the best, I am german.

__________________
Many HEMI greetings from Germany!

Black 04 Dodge Ram SLT HEMI 4x2 QC Sport, 20" wheels, LPG Gas, hard tonneau cover, leather seats.
Godfather_HEMI is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-10-2011, 06:22 AM   #2
Member
 
Godfather_HEMI's Avatar
 
Join Date: Aug 2006
Location: Germany
Posts: 51
Hi everybody.

I have a problem with my 2004 Ram HEMI. My car lose a lot coolant. I made some pictures because I don't know exactly where the problem is.

http://i399.photobucket.com/al...%20HEMI/DSC09484.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09476.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09474.jpg
http://i399.photobucket.com/al...%20HEMI/DSC09472.jpg

The rusty part looks like the servo pump but the servo pump don't need cooling water. Right? Maybe my water pump lose the cooling water? because it sit across the servo pump and the water drop to the servo pump and than to the ground?

Maybe anybody can give me a tip.


PS: Sorry my english is not the best, I am german.
__________________
Many HEMI greetings from Germany!

Black 04 Dodge Ram SLT HEMI 4x2 QC Sport, 20" wheels, LPG Gas, hard tonneau cover, leather seats.
Godfather_HEMI is offline   Reply With Quote
Old 01-10-2011, 08:45 AM   #3
Board of Directors
 
HemiByrd's Avatar
 
Join Date: Aug 2005
Location: Draffenville, KY
Posts: 25,097
Garage
I took a look at my engine to see what is around that area and could be leaking. The top radiator hose is connected just above there. Some of the factory hose clamps don't hold very well and over time a leak can happen. I had to replace a clamp on the bottom radiator hose of my truck.

By the way, your English is far better than my German.
__________________
'05 RCSB 1500 SLT 5.7 Hemi Ram - Airaid Long Snorkel UBI CAI - Taylor shorty wires - MSD Coil Packs Magnaflow y-pipe - Flowmaster 50HD - Superchips 3865 - Motive 4.56 gears - Detroit Truetrac - PML differential cover some good Karma 8.87 ET
HemiByrd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-10-2011, 08:51 AM   #4
Chauffuer to the queen
 
StudMuffin's Avatar
 
Join Date: Apr 2005
Location: Denison, TX
Posts: 2,512
take a look at your clamp and your hose, most people think they last forever, they don't. I replace mine with silacone hoses, got them from Art at Henson Motors, 1-800-530-5337 or [email protected] tell him your and HTC member for the discount. Good luck and welcome to the club.
__________________
StudMuffin is offline   Reply With Quote
Old 01-09-2012, 05:06 PM   #5
Member
 
Join Date: Feb 2011
Location: Vassar, MI
Posts: 54
im having this same problem with my 04 and it just started leakin.... dont know where from but looks kinda the same just not as bad as a problem as yours
__________________
MagnaFlow Exhaust
Hypertech Programmer
K&N CAI
Airaid TB SPacer
brcoffey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.