CEL question. Help - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 03-31-2012, 06:21 PM   #1
Junior Member
 
Join Date: Mar 2012
Location: Little Rock Ar
Posts: 7
My check engine light has been on for a while now and I finally got a chance to try and fix it. My truck is a 2004 1500 2WD SLT 5.7l Hemi. The truck would surge and the RPM's would flux about 300 RPM at speeds between 25-30 mph. I took it to auto zone and they said that there was a code for a bad egr valve but that was being caused by a low voltage output from the TPS and that my TPS was not working correctly. I did not get the code number, I know I should have. I changed out the plugs and throttle body due to having to get a TB since the TPS is not a stand alone piece. After changing these parts the truck seem to be running strong with no light, due to the battery being disconnected, but the surge was gone, but the light came back on during the first drive with in a mile. I dont want to take the truck to the dealership so I guess I will have to buy a code reader. Does anyone have any advice on where I should be looking? Thanks in advance.

__________________
2004 Ram 1500 2WD 5.7 Hemi
2011 Durango R/T 5.7 Hemi
purefun660 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2012, 06:21 PM   #2
Junior Member
 
Join Date: Mar 2012
Location: Little Rock Ar
Posts: 7
My check engine light has been on for a while now and I finally got a chance to try and fix it. My truck is a 2004 1500 2WD SLT 5.7l Hemi. The truck would surge and the RPM's would flux about 300 RPM at speeds between 25-30 mph. I took it to auto zone and they said that there was a code for a bad egr valve but that was being caused by a low voltage output from the TPS and that my TPS was not working correctly. I did not get the code number, I know I should have. I changed out the plugs and throttle body due to having to get a TB since the TPS is not a stand alone piece. After changing these parts the truck seem to be running strong with no light, due to the battery being disconnected, but the surge was gone, but the light came back on during the first drive with in a mile. I dont want to take the truck to the dealership so I guess I will have to buy a code reader. Does anyone have any advice on where I should be looking? Thanks in advance.
__________________
2004 Ram 1500 2WD 5.7 Hemi
2011 Durango R/T 5.7 Hemi
purefun660 is offline   Reply With Quote
Old 04-01-2012, 01:33 PM   #3
Junior Member
 
Join Date: Mar 2012
Location: Little Rock Ar
Posts: 7
Pulled the code today. P0405. Anyone have any ideas. From what i can gather from the net sounds like I should change the EGR valve. Anyone agree or disagree?
__________________
2004 Ram 1500 2WD 5.7 Hemi
2011 Durango R/T 5.7 Hemi
purefun660 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 10:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.