Cam phaser - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 09-11-2017, 07:50 AM   #1
Junior Member
 
Josh.vreeland's Avatar
 
Join Date: Jan 2017
Location: Foley
Posts: 27
Cam phaser

Hey guys. Just had top end rebuilt on 2013 ram. (3019.73$ ) I drive it back home. Battery very week and I go ahead replace it. Check engine light came on. Went back to mech that rebuilt top end. He's saying the code is cam phaser failure. Need some input on wtf is a cam and phaser and should this have been replaced during top end rebuild. ( my lifter roller froze up and sheared cam lobe #1 cylinder is what caused the top end rebuild )

Josh.vreeland is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2017, 11:49 AM   #2
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,004
Garage
Im going to say no, its normally not messed with doing a top end. The cam sensor is located on the fro t cover passenger side in a recess. It is held with a 10mm bolt. I usually remove the bolt and wiggle the plug until the sensor comes out. Then disconnect the electrical plug. Of course care must be taken not to break the plug by pulling on it. Look at the face of it and see if there is any physical damage. The cam sensor controls the sequential injector firing and identifies knock cylinder location. If it has physical damage then it hit it's tone ring which is the top gear of the timing chain which was removed when the cam was replaced.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 09-11-2017, 01:30 PM   #3
Senior Member
 
ric3xrt's Avatar
 
Join Date: Dec 2016
Location: Trumbauersville
Posts: 2,589
Garage
The Cam phaser is what allows the VVT system work.
this is about the best video I can find right now.
Short answer is your mechanic had to remove the phaser system to replace your camshaft since you cam was wiped , he should of replaced the Phaser , because who knows what could of wound up in the unit.
this video is also a good one to watch...I'm not implying you need to delete the system, but I think this will help you understand what it does.
ric3xrt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2017, 01:58 PM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,004
Garage
Obviously I'm not knowledgeable about the "cam phaser" and spoke of the cam sensor so please disregard my previous post. Thanks Rick for getting the correct information out. Now I'll go back to my cave.....
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 09-11-2017, 03:54 PM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
What was the code you got? This could be a simple wrong oil used code.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-11-2017, 04:22 PM   #6
Junior Member
 
Josh.vreeland's Avatar
 
Join Date: Jan 2017
Location: Foley
Posts: 27
I didn't ask for the code. Went to pick up the truck this afternoon and he printed a list of possibilities of reason why the code he had was thrown. He checked out the engine before test driving. He cleaned the sensor. Drained a tad bit of oil to check for debri . All good . One of the reasons was engine needed to be ran for a few miles ( break in) I took it home today. No lights and engine runs pretty good. Only thing noticing now is truck is super sensitive to steer adjustments while in motion . I'll mention this to tech when we look over engine once again in the morning . I'll ask for a print out of code as well.
Josh.vreeland is offline   Reply With Quote
Old 09-11-2017, 06:06 PM   #7
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
Yeah need to know the code please
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-12-2017, 06:35 AM   #8
Senior Member
 
ric3xrt's Avatar
 
Join Date: Dec 2016
Location: Trumbauersville
Posts: 2,589
Garage
Quote:
Originally Posted by Redtruck-VA View Post
Now I'll go back to my cave.....


Is the WIFI better in there?
What your behind the curve on in cam phase/VVT you more than make up for in every other aspect of these trucks.

my guy feeling is the code was thrown because the PCM needs to relearn.
ric3xrt is offline   Reply With Quote
Old 09-12-2017, 07:00 AM   #9
Junior Member
 
Josh.vreeland's Avatar
 
Join Date: Jan 2017
Location: Foley
Posts: 27
He did a relearn on the pcm. Had it all day yesterday . Dropped son off at school. Went by mech and was good. Left and 1/2 mile away code threw and kicked me out overdrive . Left truck with tech
Josh.vreeland is offline   Reply With Quote
Old 09-13-2017, 02:26 PM   #10
Junior Member
 
Josh.vreeland's Avatar
 
Join Date: Jan 2017
Location: Foley
Posts: 27
Quote:
Originally Posted by charged392 View Post
Yeah need to know the code please
The codes are P000B and P0016
Josh.vreeland is offline   Reply With Quote
Reply


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.