1st time in limp mode - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 10-05-2010, 08:49 PM   #1
Senior Member
 
bowtie crusher's Avatar
 
Join Date: May 2009
Location: Huntsville, MO
Posts: 627
1st time in limp mode

Monday morning while driving to work my ABS and park brake light came on, my speedometer was dropping from the speed I was driving to zero. The check engine light didn't come on but I was stuck in 3rd gear. I stopped at a rest area pulled my pcm fuse and checked for codes with my diablo. Truck runs fine again but when I start it up my brake light and abs light flashes and the warning bell sounds. I don't want to screw my truck up by driving it with something wrong. Any ideas? A mechanic buddy said it could be my speed sensor.

bowtie crusher is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-07-2010, 07:42 PM   #2
Senior Member
 
sppb's Avatar
 
Join Date: Mar 2007
Location: Ogdensburg, NJ
Posts: 1,738
1st time in limp mode

my map sensor did that, after reseting the pcm drive it around the block wile checking the gauges
sppb is offline   Reply With Quote
Old 10-07-2010, 10:47 PM   #3
Senior Member
 
EVILRAM07's Avatar
 
Join Date: Aug 2009
Location: NEW YORK
Posts: 866
1st time in limp mode

I had those lites come on also,but it effected my traction control , i never had anything happen with my truck being stuck in a gear though.but we put a computer on it the only codes i got was high brake fluid level,low brake fluid level and my friend at the station figured out it was the connection coming off my brake res. container,so he ordered me the res from dodge i changed it out and i have not had the problem since.
EVILRAM07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-08-2010, 06:34 AM   #4
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
1st time in limp mode

Quote:
quote:1st time in limp mode
Freeze is a expert in that.
Superjay is offline   Reply With Quote
Old 10-08-2010, 11:11 AM   #5
Senior Member
 
FAhemiST's Avatar
 
Join Date: Jul 2006
Location: Ulster County, New York
Posts: 3,150
1st time in limp mode

i was waiting for a comment like that
FAhemiST is offline   Reply With Quote
Old 10-08-2010, 12:23 PM   #6
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
1st time in limp mode

Quote:
quote:i was waiting for a comment like that
I aim to please.
Superjay is offline   Reply With Quote
Old 10-11-2010, 08:15 PM   #7
Senior Member
 
bowtie crusher's Avatar
 
Join Date: May 2009
Location: Huntsville, MO
Posts: 627
1st time in limp mode

I fixed it today, thanks fellas.
bowtie crusher is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.