03 to 05 pcm swap problems - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Like Tree12Likes
Reply
 
Thread Tools Display Modes
 
Old 02-26-2019, 01:37 PM   #1
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
03 to 05 pcm swap problems

I finally decided to do the 05 pcm swap on my 03 Ram 5.7. Everyone made it sound so simple and I haven’t had anything but problems. The swap itself was simple. But my problem now is that the truck won’t turn over, won’t click, nothing double checked all my wiring again everything matches up. It’s been starting up the past couple of days. I started it today to record a log and I let it stall before it started recording. Went to crank it back up and then that’s when nothing would happen. Keith has been working with me to tune it and he has helped out a lot with all of my questions and problems. Now I’m totally lost.

Waylon5.7 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2019, 01:48 PM   #2
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,009
Garage
So it has been starting using the 05 pcm? Started today, died and then wouldn't crank?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 02-26-2019, 01:51 PM   #3
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
Quote:
Originally Posted by Redtruck-VA View Post
So it has been starting using the 05 pcm? Started today, died and then wouldn't crank?
I’ve started it a few times today yes
Waylon5.7 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2019, 02:02 PM   #4
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
It won’t turn over. It won’t click or anything. Battery has a full charge.
Waylon5.7 is offline   Reply With Quote
Old 02-26-2019, 02:37 PM   #5
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,009
Garage
Sounds like you have lost neutral/ park safety switch. Jiggle your shift lever.. or jump the saftey switch.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 02-26-2019, 02:59 PM   #6
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
Quote:
Originally Posted by Redtruck-VA View Post
Sounds like you have lost neutral/ park safety switch. Jiggle your shift lever.. or jump the saftey switch.
jiggling the lever didn’t work. Where’s the switch located?
Waylon5.7 is offline   Reply With Quote
Old 02-26-2019, 03:18 PM   #7
Chris
 
YeahItsAHemi's Avatar
 
Join Date: Apr 2017
Location: Warren, Ohio
Posts: 2,103
Should be on the trans, not sure of the exact spot on the 545rfe. That could also be something with the trans wiring that got changed over. And triple check all the grounds
__________________
2003 QCSB "The Mutt"-392 Manley Stroker-Inertia Cam
Eagle Heads and Intake Manifold-
46RE-CRT Billet Manual Valvebody-Edge 3200 convertor
4.56 and Detroit TruTrac-Custom Morimoto Projector Headlights
Tuned by Charged392
Tons of Pics https://www.flickr.com/photos/[email protected]/albums
YeahItsAHemi is offline   Reply With Quote
Old 02-26-2019, 03:24 PM   #8
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
Quote:
Originally Posted by YeahItsAHemi View Post
Should be on the trans, not sure of the exact spot on the 545rfe. That could also be something with the trans wiring that got changed over. And triple check all the grounds
Can’t be any wire swap problems. It worked for a while after I did the swap.
Waylon5.7 is offline   Reply With Quote
Old 02-26-2019, 03:30 PM   #9
Member
 
Waylon5.7's Avatar
 
Join Date: Oct 2018
Posts: 95
I just unplugged the starter solenoid wire to see if any power was going through it. And the wire is not hot. This has got to be some dumb fix.
Waylon5.7 is offline   Reply With Quote
Old 02-26-2019, 03:37 PM   #10
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,009
Garage
Try disconnecting the battery and doing a reset.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 08:40 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.