03 Hemi idle issues - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Engine | Modifications, Repairs and Performance

Reply
 
Thread Tools Display Modes
 
Old 04-05-2017, 11:57 PM   #1
Member
 
Join Date: Feb 2017
Location: Garden Grove
Posts: 31
03 Hemi idle issues

Hey guys, been having idle issues with my truck since the battery died on me 3 weeks ago. It started off slowly & progressively got worse to the point where it won't even stay running anymore. I replaced the crank position sensor with no change at all. I replaced the APP sensor under the battery tray & that seemed to work for about a week or so with random stalling here & there. On Monday I disconnected the battery for about 4 hours to try & reset everything & after I reconnected the battery it refuses to stay running without my foot on the pedal. When it tries to run it runs rich as all hell. The motor has around 30k on it since I rebuilt it. Forged bottom end, Jay Greene custom cam, mild ported heads, 6.1 springs, SuperChips 3815 91 tune.

https://youtu.be/PyiFsUj3-OE

https://youtu.be/jMPhvpNtR14

rlk340 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-06-2017, 06:14 AM   #2
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,359
Garage
Welcome to HTC.

Any codes yet?
Ghost03hemi is offline   Reply With Quote
Old 04-06-2017, 07:51 AM   #3
Member
 
Join Date: Feb 2017
Location: Garden Grove
Posts: 31
No codes at all. Only thing I got briefly when it stalled on me while turning into a driveway was the red lightning bolt but it went away when I restarted the truck. And that was before I replaced the APP sensor & crankshaft sensor.
rlk340 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-06-2017, 09:20 AM   #4
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
Who tuned it for the cam? The trims will be way off with most any cam and cause idle hunting like it is doing along with stalling and hard starting. I see you have a superchips 91 in there so it's not tuned?
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 04-06-2017, 09:30 AM   #5
Member
 
Join Date: Feb 2017
Location: Garden Grove
Posts: 31
Jay speced the cam for the SuperChips 91 tune being that it's a 03. I've messaged him & sent him the 1st video & he's stummped on what it might be. Truck was running fine before the battery change.
rlk340 is offline   Reply With Quote
Old 04-06-2017, 10:40 AM   #6
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
__________________

SUPER BEE is offline   Reply With Quote
Old 04-06-2017, 12:20 PM   #7
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,007
Garage
I've found on the 03 after doing a reboot or tune install. Turn the ignition on and push the pedal to the floor and let it back up. Turn key off and then start the engine normally. The cam sensor can mimic the crank sensor symptoms. So if I change one I change them both. Running fat usually points at an exhaust Leake or o2s. Good luck..
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 04-06-2017, 01:50 PM   #8
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
It is doing the same thing that most of the 04+ trucks do when the trims are way off at idle they hunt around and rev up and down till the trims are learned or tune dialed in
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 04-06-2017, 02:00 PM   #9
Member
 
Join Date: Feb 2017
Location: Garden Grove
Posts: 31
My plans are to do a 05 PCM swap as soon as I get all the needed parts so I can get it tuned, but for now I just need to get it running right again. After I replaced the APP sensor I also put the truck back to stock tune & it ran good so after about, 4 days I reinstalled the 91 tune, ran fine with random stalling on me..most notably on the fwy doing about 30 mph when it it would die after letting off the throttle. I'll try what Greg suggested with the pedal & replace the cam sensor.
rlk340 is offline   Reply With Quote
Old 04-06-2017, 02:56 PM   #10
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,007
Garage
When I used the 03 pcm Keith and I spent extensive time working on idle surg and trims. Since yours ran with your current setup it should be able to repeat that tune. Trims always need to mature to steady out. The problem with the 03 is if the trims mature and then the SC tuner modifies the mature trims. It can be difficult to get back to that original tune because you are starting from a different place. My suggestion is to toss the 03 pcm as soon as possible. Keith knows 03 pcm's better than most others. You need the ability to datalog to see what's going on. Good luck..
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.