Throttle Control Warning Light - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 12-01-2016, 06:07 AM   #1
Senior Member
 
jwberry's Avatar
 
Join Date: Dec 2008
Location: Burleson
Posts: 135
Garage
Throttle Control Warning Light

I have had rough running conditions under both idle and while applying gas, would get the p0300 code. Yesterday my truck would crank but not start, this throttle control warning light came on and did not go out after 3-5 seconds, I did NOT get an engine light.
I unfortunately have no choice but to get it towed to a local shop. What all components are involved with the Throttle Control System? Anything else that can cause this? I'm not clueless just want to make sure I have my ducks in a row.

__________________
jwberry is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-01-2016, 08:26 AM   #2
Senior Member
 
jwberry's Avatar
 
Join Date: Dec 2008
Location: Burleson
Posts: 135
Garage
*Update* The throttle control warning light turns off after about 10-15 secs. and now the engine light IS on. The battery voltage gauge is showing low voltage, but the engine cranks fine, just will not start. Like it is not getting fuel.
Has a new fuel pump and I can hear it engaging.
__________________
jwberry is offline   Reply With Quote
Old 12-01-2016, 10:48 AM   #3
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,102
Garage
Do have a test fitting on the fuel rail? You could check for pressure. Replace the battery and fully charged it. Clean terminals and grounds. Check electrical connection to the TB, clean and use a little dielectric grease. Pull a plug on each bank to see if it is wet with fuel or dry. This should get you started. Good luck..
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-01-2016, 12:36 PM   #4
Senior Member
 
jwberry's Avatar
 
Join Date: Dec 2008
Location: Burleson
Posts: 135
Garage
No pressure from the fuel pump at all. It was trying to turn which is what I was hearing from it, but wasn't doing anything. So the f'en pump was no workie workie.
I did clean the TB and connections a while back, but will do that again. Also having the battery charged, it was fairly new so I'll just keep an eye on it.
__________________
jwberry is offline   Reply With Quote
Old 12-01-2016, 01:15 PM   #5
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,102
Garage
Good it sounds like it's the pump. If you take the gas cap off and listen you can really hear the pump running when it's working. If it sounds like it's got no load on it. It may be the fuel pickup fell off inside the tank. Of course....
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 12-01-2016, 01:34 PM   #6
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,175
Exclamation

Could be the 'new' fuel pump is bad/defective . Unfortunately in today's world parts aren't what they use to be in many cases .



__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:18 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.