PS Fluid in Inner Tie rod boots? - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 08-04-2017, 07:54 PM   #1
Member
 
Heywood's Avatar
 
Join Date: Jun 2008
Location: Sacramento
Posts: 64
Question PS Fluid in Inner Tie rod boots?

Last time I was at the dealer they indicated the left inner TR had excessive play. Turned out to be the hub but that's another story.

So while I was replacing the upper and lower ball joints today I went ahead and replaced the inner and outer tie rods / ends. I already had the parts so I went ahead and did the inners anyways even though they didn't feel as bad as I would expect for 223k mi.

As I pulled the boot, to my surprise it dumped PS fluid all over my driveway. I have to say I don't think this is normal. Both sides did it (but I was ready with a catch pan the 2nd time). Are there seals that I can replace or do I have to replace the whole rack?

__________________
2005 1500 QC 4x2
Heywood is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-04-2017, 08:30 PM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,270
Garage
It's normal for them to sweat a little over time but if it ran out when you pulled the boot off it's likely time for a rack and pinion. The seals in there are not serviceable to my knowledge.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 08-05-2017, 02:53 AM   #3
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,101
Garage
The rack on my truck has mysteriously repaired itself a few times. After sitting for an extended period of time it has dumped fluid on startup. The first time it did this, the inspection sticker had expired and needed the truck on the road immediately. I used brake cleaner and got the mess cleaned up. Topped off the resovior and had it inspected with full intentions of replacing the r&p. It didnt leak for a couple more years, again after sitting for a few months. My son in laws 04 did the same thing. Seems if the old truck sits for more than a month it pukes fluid then goes back to being sealed. If its leaking from the high pressure hose. Putting a hose clamp on it solves the problem. Its just a bit quirky....
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-05-2017, 09:28 AM   #4
Member
 
Heywood's Avatar
 
Join Date: Jun 2008
Location: Sacramento
Posts: 64
About 6 mos ago I replaced both lines from the cooler. I tried new hose clamps, and that worked for a bit but the leak returned. Haven't seen a drop since new hoses. Cheap fix too, < $30 IIRC. The dump of fluid from the boots was a surprise.
ETA:
@Charged, yeah it was more than a little 'sweat'. Open a bottle of new fluid and turn it upside down on the driveway...
__________________
2005 1500 QC 4x2
Heywood is offline   Reply With Quote
Old 08-05-2017, 09:49 AM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,270
Garage
Oh damn yeah not good that's to much
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 07:20 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.