need to smog...p0430 popped - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 03-28-2019, 06:52 PM   #1
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
need to smog...p0430 popped

Hey All, smog test time and wouldn't you know it, popped a p0430. So I replace the passenger side rear sensor with an NTK sensor...drove around for about 25 miles and 3 of the 4 monitors came up good on my reader..the cat one still flashing so I figured a few more miles. Drove to work this morning and the P0430 popped again, reset it for the drive home (25 mile) and by the time I got there 3 of the 4 monitors were good..only the cat monitor still flashing. I'm hoping the cat monitor goes good and not pop a p0430. But thinking ahead just in case, I think the cat is ok because the truck seems to be running good, so I'm thinking to do 1, 2 or all of the following:

1) swap the 02's and see if the problem follows...
2) maybe get another NTK sensor and replace the driver side as well
3) maybe swap in a 190, 195 or stock thermostat temporarily so the fuel mixture isn't richened (which can also throw a p0430.

let me know what you all think...freddie

__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-28-2019, 06:56 PM   #2
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
Also, anyone running a 190 or 195 tstat? have the autozone or oreilly part # handy?
__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Old 03-28-2019, 07:41 PM   #3
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,098
Garage
Good to hear from you Freddie. I would start out by swapping the sensors. Do you have any old sensors you can swap in? I seem to have better luck with junk yard sensors than new ones... you could also temporarily remove them and tie them out of the way to see if they clear.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-29-2019, 12:58 PM   #4
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
I swapped in a stock tstat last night and she runs right at 203-204 now. drove to work and cat still flashing but no code thrown yet...
__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Old 03-29-2019, 02:25 PM   #5
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,098
Garage
I think it has to cycle a number of times before its completely gone.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 03-30-2019, 01:33 PM   #6
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
ok..used my reader and found deeper codes in a different area (p0533 and p0300)..I cleared them and we'll see later if it works...
__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Old 03-30-2019, 01:55 PM   #7
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,098
Garage
There is a relation between the two as the sensor is also suppose to raise high idle during ac load which could look like a misfire.
My guess is bad sensor or wiring.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 04-01-2019, 11:35 AM   #8
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
hmmm..that's something to think about...I threw the code again this morning so I'll swap sides to see if it follows..
__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Old 04-04-2019, 08:21 PM   #9
Mark G Senior Member
 
bada44's Avatar
 
Join Date: Jul 2006
Location: St Augustine FL
Posts: 1,641
Garage
You might want to change all of the O2 sensor so they are all the same.... Just a thought when I changed out mine I changed them all out at the same time and had no more issues.
__________________
Every 2 minutes a new child is diagnosed with cancer & 1 in 5 children diagnosed with cancer will not survive!
Please Donate today!
https://www.stbaldricks.org
I stand for the flag!

Engine built by Go For Broke performance
[email protected]
bada44 is offline   Reply With Quote
Old 04-07-2019, 03:37 PM   #10
Senior Member
 
chefred112's Avatar
 
Join Date: Jan 2007
Location: Tracy, CA
Posts: 4,307
Garage
I put my plug foulers back on for passenger side and the cat code went away...I'm going to have my cutouts flanged and have a straight pipe put in it's place for now, I decided to do this when I went to a smog place and as I was driving by I saw a guy crawl underneath a car to inspect it...ughhh..I kept on driving, lol.
__________________
__________________________
-fast freddie- 392 hemi :)
http://www.dragtimes.com/Dodge-Ram-1500-Timeslip-23591.html?r=1"]2005 Dodge Ram 1500 SLT: 12.10 @ 113.96 MPH
chefred112 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.