Mystery part? - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 02-03-2018, 05:22 PM   #1
Junior Member
 
Join Date: Feb 2018
Location: Port Clinton
Posts: 6
Mystery part?

Can anyone tell me what this component is? I have no idea what it is, does, or goes. I found it sitting loose behind the panel under the steering column.
Attached Images
File Type: jpg KIMG0076_1517700102821.jpg (33.4 KB, 22 views)

MrMopar is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2018, 06:10 PM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,265
Garage
Looks like the shifter interlock sensor. I believe not 100% on this that there is two cables near the column under the dash and one should have a round section in it and I think that’s where that goes.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 02-03-2018, 09:16 PM   #3
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,175
Thumbs up

Quote:
Originally Posted by [B
MrMopar[/B];421161]Can anyone tell me what this component is? I have no idea what it is, does, or goes. I found it sitting loose behind the panel under the steering column.
----------------------------------------
MrMopar To The HTC




__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2018, 10:15 PM   #4
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,663
Garage
__________________

SUPER BEE is offline   Reply With Quote
Old 02-04-2018, 12:15 AM   #5
tui
Senior Member
 
tui's Avatar
 
Join Date: Nov 2010
Location: New Zealand
Posts: 767
Garage
Dont know, but it looks dangerous!!
tui is offline   Reply With Quote
Old 02-04-2018, 08:04 AM   #6
Queen Kima - Whemi BOD
 
Mrs.Studmuffin's Avatar
 
Join Date: Sep 2005
Location: Denison, TX
Posts: 10,279
__________________
.
Not everyone can be queen.....there has to be someone standing on the curb to wave as I go by.
.

Mrs.Studmuffin is offline   Reply With Quote
Old 02-04-2018, 08:19 AM   #7
Junior Member
 
Join Date: Feb 2018
Location: Port Clinton
Posts: 6
Thanks for the comments, from them I have deduced that it is the BTSI brake transmission security interlock solenoid. This prevents putting the truck in gear when ignition off. Apprently it failed and previous owner just disconnected it. My key fobs do not work, and shop scan tool could not see the security module, I found out why when looking at the BTSI, appears to be an aftermarket remote start wired in. Springtime wiring project!
MrMopar is offline   Reply With Quote
Old 02-04-2018, 05:26 PM   #8
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,265
Garage
Thought so lol.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 09:09 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.