i have no power! - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 01-03-2017, 05:48 PM   #1
Junior Member
 
Join Date: Jan 2017
Location: jackson
Posts: 7
i have no power!

i have a 2003 ram 2500 with the 5.7 hemi. i just put in a slightly built motor( i blew up the old one) and now i have no power. the dome light and headlights work but no cluster and no start no response to turn of key (all fuses are good). i grounded everything to see if that would help. but it didn't change anything. i am open to any and all ideas thanks in advance.

huntmaster56 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-03-2017, 06:11 PM   #2
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,089
Garage
Did you attach the ground straps to the rear of the heads?
Do you have the ASD relay plugged in?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 01-03-2017, 06:13 PM   #3
Junior Member
 
Join Date: Jan 2017
Location: jackson
Posts: 7
yes i grounded valve covers to head heads to block both heads together and block to frame
huntmaster56 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-03-2017, 07:08 PM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,089
Garage
That sounds like it should be enough. The original just had braided ground straps from the back of the heads to the cab. Will need to see if power is being fed from the IPM. Do you hear the fuel pump run with the key turned on . Did the truck run before you changed engines?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 01-03-2017, 07:09 PM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,262
Garage
Make sure engine ground wire from battery is there the big cable drivers side near front cover area. Also you didn't pinch the harness in the middle of the trans and engine did you seen that before
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 01-03-2017, 08:24 PM   #6
Junior Member
 
Join Date: Jan 2017
Location: jackson
Posts: 7
Quote:
Originally Posted by Redtruck-VA View Post
That sounds like it should be enough. The original just had braided ground straps from the back of the heads to the cab. Will need to see if power is being fed from the IPM. Do you hear the fuel pump run with the key turned on . Did the truck run before you changed engines?
yes truck ran till i spun the bearings no fuel pump is not priming
huntmaster56 is offline   Reply With Quote
Old 01-03-2017, 08:25 PM   #7
Junior Member
 
Join Date: Jan 2017
Location: jackson
Posts: 7
Quote:
Originally Posted by charged392 View Post
Make sure engine ground wire from battery is there the big cable drivers side near front cover area. Also you didn't pinch the harness in the middle of the trans and engine did you seen that before

harness is not pinched and the ground is attached
huntmaster56 is offline   Reply With Quote
Old 01-03-2017, 08:31 PM   #8
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,089
Garage
Dead battery? Looks like you will just go step by step until you get no power. Was the IPM taken out for any reason?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 01-03-2017, 08:33 PM   #9
Junior Member
 
Join Date: Jan 2017
Location: jackson
Posts: 7
Quote:
Originally Posted by Redtruck-VA View Post
Dead battery? Looks like you will just go step by step until you get no power. Was the IPM taken out for any reason?
battery has 12.34 volts no the ipm wasnt removed im thinking possibly ignition but i dont know how to test that
huntmaster56 is offline   Reply With Quote
Old 01-03-2017, 08:47 PM   #10
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,262
Garage
If all is good and now it simply won't start that's the only likely culprit besides the time taking a crap.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.