heater fan keeps running - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 08-21-2016, 03:04 PM   #1
Junior Member
 
Join Date: Aug 2016
Location: North Smithfield
Posts: 2
heater fan keeps running

Hello everyone, I searched threads for this topic but found nothing. My heater fan keeps running even with the truck off and the key out. I replaced the ignition switch and it did not solve the problem. There was no charring on the contacts as some have noted this may have caused the problem. Someone else mentioned that it could be the resistor on the fan motor itself. Seems unlikely as it should not get power to the resistor if the key is out. Before I go and buy another part does anyone have any suggestions? It is a 2005 ram 1500 with the Hemi.

dcard1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2016, 03:46 PM   #2
Junior Member
 
Join Date: Aug 2016
Location: North Smithfield
Posts: 2
update

actually another question. I can find the blower motor resistor. Its under the passenger dash, is $30 and easy to replace. The questions is where do I find the blower motor relay? It is not in the fuse box under the hood. I removed every resistor in the box under the hood and the fan continues to run without the keys in it.
dcard1 is offline   Reply With Quote
Old 08-21-2016, 06:44 PM   #3
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,273
Garage
The ignition switch supply's the power on our trucks. So something has to be wrong in there. The weird part is you said you changed it. If you unplug the switch does the blower go off?
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-21-2016, 07:41 PM   #4
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,175
Thumbs up

dcard1






__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 08-22-2016, 03:31 AM   #5
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,429
fuse block for an 05 shows a relay
Attached Images
File Type: jpg 2012-08-13_183247_1.jpg (54.0 KB, 10 views)
__________________
boedacres is offline   Reply With Quote
Old 08-22-2016, 06:13 AM   #6
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,273
Garage
On my 2005 that's the Condensor fan relay not the blower. The SRT10 has a blower relay there not a normal v8 truck. The 2005 is ignition switch controlled power
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 08-22-2016, 09:24 AM   #7
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,664
Garage
__________________

SUPER BEE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 11:46 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.