Broken ground cable? - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > General Repair Forum

Reply
 
Thread Tools Display Modes
 
Old 06-17-2017, 08:15 PM   #1
Senior Member
 
JustHemi's Avatar
 
Join Date: Feb 2005
Location: Greenwood
Posts: 6,381
Broken ground cable?

Found a broken ground cable I believe that goes way up somewhere on the back of the motor and was clipped on the passenger side wheel well behind the plastic liner after i pulled it. Found it while doin my exhaust. Looks like the pass cat mustv burnt through it or something. Anyone know what or where this goes and how important it is?

JustHemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-17-2017, 08:42 PM   #2
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,105
Garage
IMO all grounds are important. It goes to the rear of the passenger's side head. Then over to the drivers head.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 06-17-2017, 09:19 PM   #3
Senior Member
 
JustHemi's Avatar
 
Join Date: Feb 2005
Location: Greenwood
Posts: 6,381
This doesnt attach to a head. It was crossing over the passenger side exhaust. And i cant even get my hand up to where it starts. Seems mid engine up high somewhere. Might b passenger head. Have to look a little better but it was attached w a clip out to the fender
JustHemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-17-2017, 09:21 PM   #4
Senior Member
 
JustHemi's Avatar
 
Join Date: Feb 2005
Location: Greenwood
Posts: 6,381
I will try to get a good pic tomorrow. I agree tho. Might b part of my idle roughness although thats been considerably better w the new Amsoil air filter and i assume w the new exhaust it should b too aince it was leakin and had a clogged cat. Lol
JustHemi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.