installed new cats, now throwing P0420 - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Exhaust | Mufflers. Tips and Headers

Reply
 
Thread Tools Display Modes
 
Old 04-15-2010, 05:03 AM   #1
Senior Member
 
BigBlue88's Avatar
 
Join Date: Mar 2009
Location: Whidbey Island, Washington
Posts: 238
installed new cats, now throwing P0420

installed magnaflow high flow cats and now all of a sudden im getting a code. is it a bad o2 sensor or a bad cat? i can clear it and it takes a couple days but it still comes back.

BigBlue88 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2010, 05:45 AM   #2
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
installed new cats, now throwing P0420

Get an O2 sim from 3rd Strike and you'll be fine!
MrHemi is offline   Reply With Quote
Old 04-15-2010, 04:24 PM   #3
Senior Member
 
HemiCane's Avatar
 
Join Date: Jun 2006
Location: Lantana, FL
Posts: 173
installed new cats, now throwing P0420

I stacked two spark plug non-foulers on each side and it took care of the CELs. I got them at the local parts store, don't remember which one exactly.
HemiCane is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2010, 04:43 PM   #4
Senior Member
 
madcat's Avatar
 
Join Date: Feb 2007
Location: Royse City, TX
Posts: 8,558
installed new cats, now throwing P0420

Quote:
quote:Originally posted by HemiCane:
I stacked two spark plug non-foulers on each side and it took care of the CELs. I got them at the local parts store, don't remember which one exactly.
They are in the "help" section of autozone. Part# 49002. They did NOT fix mine however. I just picked up some steel wool today, will try to pack them later when exhaust cools down.
madcat is offline   Reply With Quote
Old 04-15-2010, 10:00 PM   #5
Senior Member
 
Starchief_59's Avatar
 
Join Date: Sep 2007
Location: San Marcos, Texas
Posts: 3,496
installed new cats, now throwing P0420

I gutted my cats and I just dealt with the code for over a year. I have the spacers now but one side still throws a code. I guess I'll try to stack them
Starchief_59 is offline   Reply With Quote
Old 04-16-2010, 05:18 AM   #6
Member
 
MonteMuscle1970's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 91
installed new cats, now throwing P0420

I just picked up the Dynatech system for my Daytona. I'm half expecting to run into this problem after installation. I could do the sims, but I'm gonna wait to see what happens. My question is, does spacing the o2's cause any other issues? I know sometimes highflows throw codes, and this can get around that, but is it really ok to do? It won't cause any other issues? (And I don't just mean with the CEL/MIL lights, but PCM/ECU calibration)
MonteMuscle1970 is offline   Reply With Quote
Old 04-16-2010, 10:19 AM   #7
Senior Member
 
madcat's Avatar
 
Join Date: Feb 2007
Location: Royse City, TX
Posts: 8,558
installed new cats, now throwing P0420

the REAR 02 sensors are only there to let the PCM know that the CATS are working correctly for emissions reason. NO changes in AFR are made by the PCM when readings are high or low.
madcat is offline   Reply With Quote
Old 04-16-2010, 09:54 PM   #8
Senior Member
 
slchemi's Avatar
 
Join Date: Jun 2005
Location: Salt Lake City, UT
Posts: 1,009
installed new cats, now throwing P0420

Quote:
quote:Originally posted by MonteMuscle1970:
I just picked up the Dynatech system for my Daytona. I'm half expecting to run into this problem after installation. I could do the sims, but I'm gonna wait to see what happens. My question is, does spacing the o2's cause any other issues? I know sometimes highflows throw codes, and this can get around that, but is it really ok to do? It won't cause any other issues? (And I don't just mean with the CEL/MIL lights, but PCM/ECU calibration)
You will. I dealt with it for about a year, then put in one of the spark plug non-foulers and it came back. I then stacked two of them like other members have done, and it will still come back occasionally, but the truck will clear it within a few days. I am going to try the steel wool pack or tin foil pack next.
slchemi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 07:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.