02 problem, what else is new? - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Exhaust | Mufflers. Tips and Headers

Reply
 
Thread Tools Display Modes
 
Old 08-02-2013, 01:28 PM   #1
Member
 
MonteMuscle1970's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 91
02 problem, what else is new?

I've got a P0157 code (low voltage bank 2 sensor 2) and I replaced the sensor and it was off for a day. Now its back on. The code comes on when I start the truck. I thought the 02's didn't register until it went into open loop?

I've got dynatech headers and high flow cats into the stock Borla exhaust (Daytona). I need to get it inspected ASAP. I have a diablosport and the performance tune is running right now. I don't know anything about the diagnostics, but when I was looking at the live feedback it seemed like that sensor was reading 0.00volts the whole time. Could the intermediate wire be dead and would that cause this code?

MonteMuscle1970 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-04-2013, 07:27 AM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
I believe that is a 4 wire sensors test the plug with key on

Put connector clip up test top two pins together and bottom two pins together one set should have 12v with key on meaning heater circuit is good other set should have .4-.5 meaning sensor bias voltage is there that's the voltage that's causin the code if its not there either there is a broken wire at connector or the PCM is not working correctly
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 08-04-2013, 07:56 AM   #3
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,350
Garage
Bank 2, sensor 2 believe that's your cat o2 sensor. (O2 sensors after the cats). If your o2 sensor is good to go. Believe your high flow cats are the cause for the codes.
Ghost03hemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-04-2013, 07:09 PM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,004
Garage
Agree with the above statements. low voltage, maybe bad O2s or cat?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 09-06-2013, 03:22 PM   #5
Member
 
MonteMuscle1970's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 91
Turns out it was the extension wire from the sensor to the wiring harness. I have dynatech LT's so they came with them. It was corroded. Ordered a new one from summit racing from Casper(?) I think. But that fixed it. Now it turned on P0420 and P0430 though lol.
What are the methods for getting rid of those? Bung spacers? Get a custom tune? Gotta pass state inspection in MA, and I'm not getting rid of my headers! lol.
MonteMuscle1970 is offline   Reply With Quote
Old 09-06-2013, 06:23 PM   #6
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
Spacers seem to work for most people a tune is the best way thou
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-10-2013, 08:43 PM   #7
Member
 
MonteMuscle1970's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 91
Where would I go to get a custom tune? I don't know of any shops around here that do it, especially for Dodge stuff. Everyone I know runs an LSx motor. I don't know much about tuning in general. What kind of tune would I be looking for? Something done on a dyno?
MonteMuscle1970 is offline   Reply With Quote
Old 09-10-2013, 09:31 PM   #8
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
Go to diablosports website and do a cmr dealer search for your area or state and then call them and let them know you need a tune for 02 sensor delete
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 01:52 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.