Help - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Performance Zone > Induction | Super Chargers, Turbo & Air Intakes

Reply
 
Thread Tools Display Modes
 
Old 02-09-2008, 12:12 PM   #1
BamaRam\er
Guest
 
Posts: n/a
Help

AFE long tube intake w/ AMS Filter... I took everything apart for inspection & my throttle body (with a lil brake cleaner) is rubbing black on inside of TB as far as the finger will go!!! What is happening to cause this???

  Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-2008, 12:19 PM   #2
Senior Member
 
Scion's Avatar
 
Join Date: Aug 2005
Location: Idahemi Falls, ID
Posts: 1,911
Help

Likely PCV valve...maybe EGR, too. Gotta love emissions systems.
Scion is offline   Reply With Quote
Old 02-09-2008, 12:21 PM   #3
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
Help

Is your AMS filter an oiled or dry filter?
MrHemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-09-2008, 01:41 PM   #4
BamaRam\er
Guest
 
Posts: n/a
Help

Hey Mark, Its dry I believe, AMS EAAU 3590....I had just recently purchased a airraid top mount & in the midst of the install, Instro's told me to cut my AIT wire to stretch it out....WELL!!!............"I'm a fat boy in gym class, I aint playing"!!!!!! If it dont fit, I ainta gonna use it!!.......Would the PCV , EGR cause that much damage????
  Reply With Quote
Old 02-09-2008, 01:51 PM   #5
Senior Member
 
Freeze's Avatar
 
Join Date: Jun 2004
Location: Virginia Beach, VA
Posts: 13,698
Help

What kind of oil are you using and how many miles do you have on your truck?
Freeze is offline   Reply With Quote
Old 02-09-2008, 01:51 PM   #6
BamaRam\er
Guest
 
Posts: n/a
Help

Thank's for the reply's guy's...Pulled the old filter & installed a new 3590, AFTER cleaning as much of the TB as I could get to as to..."PER previous post" The deeper I got into the TB, the cleaner it was...I remembered an old post about TB cleaning & I went with what I thought was right......
  Reply With Quote
Old 02-09-2008, 01:52 PM   #7
BamaRam\er
Guest
 
Posts: n/a
Help

Ams 5-20 , 13,565
  Reply With Quote
Old 02-12-2008, 02:20 PM   #8
BamaRam\er
Guest
 
Posts: n/a
Help

Thank's guy's,.....only the TB was dirty... the old filter was dirty also.. the air tubes were spotless.......Had to stay with the ol' long tube CAI....I unchipped it & reset the pcm & my milage is still going down....15,14,13.8, wtf...???....I bought this trk 6,500miles on it..could it be something the dip-**** salesman did while he had it on demo????
  Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 12:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.