LED tail light bulbs - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Headlights and Lighting

Reply
 
Thread Tools Display Modes
 
Old 12-30-2015, 10:28 AM   #1
Senior Member
 
HEMI COMMANDER's Avatar
 
Join Date: Dec 2007
Location: Auburn, Georgia
Posts: 861
LED tail light bulbs

I just put some LED bulbs in my 2011 and the computer don't like them, it tells me the lights are out and the turn signals flash rapidly just like when a bulb is blown. Anyone have a suggestion to fix this?

__________________
GO DAWGS GO

RIP Commander RIP!

New Ride
2011 1500 SLT-Satellite Radio, Nitto Terra GrapplerTires... Working on MODS

HEMI COMMANDER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-30-2015, 10:54 AM   #2
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,172
Lightbulb

- Most if not all LED bulbs are 'one direction polarity' I found this out when I bought some high dollar, high power LED backup lights. I just switched the bulb around in the socket and all-was-good. Also you may(?) need a resistor inline to stabilize the voltage draw as compared to the regular conventional bulbs which draw more current.


__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 12-30-2015, 11:28 AM   #3
Senior Member
 
HEMI COMMANDER's Avatar
 
Join Date: Dec 2007
Location: Auburn, Georgia
Posts: 861
Thanks I talked with Sylvania and they told me that I need a load equalizer, they suggestion that I get it from AutoZone....funny thing about that is I called AutoZone and they don't carry it.
__________________
GO DAWGS GO

RIP Commander RIP!

New Ride
2011 1500 SLT-Satellite Radio, Nitto Terra GrapplerTires... Working on MODS

HEMI COMMANDER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-30-2015, 02:40 PM   #4
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,172
Quote:
Originally Posted by HEMI COMMANDER View Post
Thanks I talked with Sylvania and they told me that I need a load equalizer, they suggestion that I get it from AutoZone....funny thing about that is I called AutoZone and they don't carry it.
----------------------------------------
Look on the RECON web site...RECON Truck Accessories - Your Source for LED Vehicle Lighting Accessories I know they carry them for their LED retrofit lights.


__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 01-01-2016, 05:00 PM   #5
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,447
Garage
6 ohm, 50 watt resistor across the circuit. That will fake out the computer so it'll see a load.
__________________
MikeHTally is offline   Reply With Quote
Old 01-01-2016, 05:10 PM   #6
Gary
 
leadfoot's Avatar
 
Join Date: Jun 2007
Location: Staten Island, NY
Posts: 904
The flasher for the signal needs to be changed under the dash to an led one . That will stop fast blinking. Not sure about light out on dash
__________________
Old ride
03 ram quad cab hemi

New ride
2013 Ram Crew Cab Sport
No Mods
leadfoot is offline   Reply With Quote
Old 01-01-2016, 05:31 PM   #7
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,447
Garage
Pretty sure the flasher is not replaceable so easily. It isn't a plug-in, it's a soldered-in relay that emulates the "click-click" of a flasher. MUCH easier to just load the circuit.
MikeHTally is offline   Reply With Quote
Old 01-01-2016, 05:42 PM   #8
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,172
Thumbs up

Quote:
Originally Posted by MikeHTally View Post
Pretty sure the flasher is not replaceable so easily. It isn't a plug-in, it's a soldered-in relay that emulates the "click-click" of a flasher. MUCH easier to just load the circuit.
--------------------------------------------
On the older 03-05 trucks things are easier it seems...most of my LED add-ons have just been plug-n-play .
__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 01-01-2016, 06:08 PM   #9
Senior Member
 
HEMI COMMANDER's Avatar
 
Join Date: Dec 2007
Location: Auburn, Georgia
Posts: 861
Got a resistor for a LED light shop and that fixed the problem. Thanks guys for the help.
__________________
GO DAWGS GO

RIP Commander RIP!

New Ride
2011 1500 SLT-Satellite Radio, Nitto Terra GrapplerTires... Working on MODS

HEMI COMMANDER is offline   Reply With Quote
Old 01-02-2016, 08:44 AM   #10
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,172
Thumbs up

Great info & fix

__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 12:55 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.