Gauge Cluster - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Headlights and Lighting

Reply
 
Thread Tools Display Modes
 
Old 02-21-2014, 07:51 PM   #1
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
Gauge Cluster

My high beam indicator LED doesn't work. Has anyone replaced this LED or does this require gauge cluster replacement? I don't really need it to work as my fog light indicator LED still comes on when I am using the low beams.

__________________

SUPER BEE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-23-2014, 06:47 AM   #2
Farrrrrr East Coast
 
NewfieBullet's Avatar
 
Join Date: Apr 2008
Location: Newfoundland Canada
Posts: 3,764
Garage
pretty sure the 3rd gens just use little bulbs for all those lights.
__________________
Check Out My Garage For Mods and Pics, There's A Few :P

NewfieBullet is offline   Reply With Quote
Old 02-23-2014, 11:29 PM   #3
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
The gauge cluster is illuminated by 5 small light bulbs which back light the gauges. All the indicator lights are LED's as per the repair manual on the 2007 Dodge Ram. Over time these LED's can fail, and I think that has happened with my high beam indicator.
__________________

SUPER BEE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-03-2014, 02:52 AM   #4
Farrrrrr East Coast
 
NewfieBullet's Avatar
 
Join Date: Apr 2008
Location: Newfoundland Canada
Posts: 3,764
Garage
not sure on the dash but everything else on mine are leds soldered onto a board, kinda hard to change out
__________________
Check Out My Garage For Mods and Pics, There's A Few :P

NewfieBullet is offline   Reply With Quote
Old 03-03-2014, 06:17 AM   #5
Ramless Member
 
Ramsey88's Avatar
 
Join Date: Jan 2013
Location: 'Murica
Posts: 1,036
Garage
Harrold, do you have a part # for the little bulbs that illuminate the hvac controls? Mine went out last week
__________________
------------------------------------------------------

2015 Harley Iron 883 Daddy's toy

2014 Focus SE sedan 2.0L gas-sipping gokart for the wife and kid

07 QCSB HEMI 3.92 LSD 2WD-- gone but never forgotten.



Ramsey88 is offline   Reply With Quote
Old 03-03-2014, 02:06 PM   #6
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
Cool

Check on Amazon as they have a set of bulbs with sockets for the AC controls.
__________________

SUPER BEE is offline   Reply With Quote
Old 03-03-2014, 02:12 PM   #7
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
Cool

I found out, a couple of days ago, how to do a gauge cluster operational check. All my gauges worked fine, but I did discover that my high beam, brake, and ABS LED's are inoperative. I think I will have to pull the gauge cluster and send it to a repair facility.
__________________

SUPER BEE is offline   Reply With Quote
Old 03-03-2014, 03:55 PM   #8
Gold-Member
 
kcd1369's Avatar
 
Join Date: Oct 2004
Location: Brandon, FL
Posts: 4,045
Garage
Quote:
Originally Posted by Harley Harrold View Post
I found out, a couple of days ago, how to do a gauge cluster operational check.
OK don't keep that info to yourself, how do you do the test?
__________________
05 1500 SLT Quad Black on Black | Pace Setter Long Tubes | Magna Flow Cat Back | Doug's Electric Cutout | Custom Ram Air Hood | Spyder LED Tails | Spec-D Black Projectors W/Halos | Flex-A-Lite E-Fan |Jet 180 Stat | K&N CAI | 20 inch wheels | Comp 268 Cam W/6.1 push rods and springs | Diablo Trinity | Custom Tune by Charged392.





kcd1369 is offline   Reply With Quote
Old 03-04-2014, 08:44 PM   #9
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,646
Garage
Very simple to test, just push in the trip odometer reset and hold in while turning your ignition switch to the on position, then release the trip odometer rest. The gauges will move to different positions, and all your indicator lights will illuminate. It takes about a minute to run the complete test. At the end your gauge cluster will return to what you normally see when turning the ignition switch to the on position.
__________________

SUPER BEE is offline   Reply With Quote
Old 03-04-2014, 09:16 PM   #10
Gold-Member
 
kcd1369's Avatar
 
Join Date: Oct 2004
Location: Brandon, FL
Posts: 4,045
Garage
Quote:
Originally Posted by Harley Harrold View Post
Very simple to test, just push in the trip odometer reset and hold in while turning your ignition switch to the on position, then release the trip odometer rest. The gauges will move to different positions, and all your indicator lights will illuminate. It takes about a minute to run the complete test. At the end your gauge cluster will return to what you normally see when turning the ignition switch to the on position.
Cool deal. Thanks.
__________________
05 1500 SLT Quad Black on Black | Pace Setter Long Tubes | Magna Flow Cat Back | Doug's Electric Cutout | Custom Ram Air Hood | Spyder LED Tails | Spec-D Black Projectors W/Halos | Flex-A-Lite E-Fan |Jet 180 Stat | K&N CAI | 20 inch wheels | Comp 268 Cam W/6.1 push rods and springs | Diablo Trinity | Custom Tune by Charged392.





kcd1369 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:37 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.