Dim dash lights. - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Headlights and Lighting

Reply
 
Thread Tools Display Modes
 
Old 01-20-2017, 04:28 PM   #1
Junior Member
 
Join Date: Jan 2017
Location: Hemet
Posts: 4
Unhappy Dim dash lights.

Dash lights will dim at certain times and return to normal also back up camera will lag for a short time before functioning. Any advice would be great. Thanks in advance.

waxman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-20-2017, 04:41 PM   #2
Matt
 
MANual_puller's Avatar
 
Join Date: Mar 2014
Location: Vinton
Posts: 2,652
Garage
Quote:
Originally Posted by waxman View Post
Dash lights will dim at certain times and return to normal also back up camera will lag for a short time before functioning. Any advice would be great. Thanks in advance.
Do they happen at the same time or are we looking at two different problems?
__________________
2011 Ram 2500 ST 4x4, 5.7L Hemi, crew cab, short box, 4:10 gear ratio with rear LSD, 180 amp alternator, tow mirrors w/ puddle and signal lamps, popular options group, carpet deleted, Ranch Hand front bumper, 9500# winch, pair of 100w KC lights, Magnum RT steps, Line-x sprayed bedliner, stampede o/e style fender flares, Ram branded oversize rubber mud flaps, stampede smoked bug deflector, Dee Zee toolbox

MANual_puller is offline   Reply With Quote
Old 01-20-2017, 04:50 PM   #3
Junior Member
 
Join Date: Jan 2017
Location: Hemet
Posts: 4
Same problem.
waxman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-20-2017, 06:24 PM   #4
Senior Member
 
CavRam's Avatar
 
Join Date: Jun 2004
Location: GA
Posts: 1,808
Our trucks have an amazing amount of electronics. Start with the basics. Ensure grounding points under the dash are clean/secure and ensure your battery and charging system is healthy. You will be amazed at the weird symptoms a sub-par battery will create.
__________________
2014 Ram 1500 Express
CavRam is offline   Reply With Quote
Old 01-21-2017, 05:12 AM   #5
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,302
Garage
Yes like stated make sure batt and alternator are working/charging solid. If they are good double check the grounds you can see in the engine bay from battery to frame they sometimes corrode. If they are good then it's likely something inside and the real diagnosis needs to start
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 01-21-2017, 08:52 AM   #6
Junior Member
 
Join Date: Jan 2017
Location: Hemet
Posts: 4
Thanks for the info I'll check the electrical system.
waxman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.