finally got new rubber - Page 2 - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Running Gear | Brakes, Wheels and Tires

Reply
 
Thread Tools Display Modes
 
Old 03-06-2008, 06:45 PM   #11
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
finally got new rubber

Quote:
quote:Is it just me or when Jay talks about rubber we all get a weird image in our heads
Yep, it's you. Ya know, the one who doesn't put a smiley after his posts, so we know how he means it!

Superjay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-06-2008, 08:10 PM   #12
Senior Member
 
sppb's Avatar
 
Join Date: Mar 2007
Location: Ogdensburg, NJ
Posts: 1,738
finally got new rubber

Ok, I went to Midas and got them mounted today, after a long chat with the girl at the front desk trying to explain why Hemi owners need oversize rubbers I got the price down to $83.00 for the full service including disposal of the used rubbers, I know its cheep but she couldn’t resist my charm.
Now my first impression after 40 miles is wow it’s like gliding I mean there is not a minor sound coming off this tires even at 100 mph, incredible traction on dry, can barely spin them at take off but yes you get stuck to the seat.
I will keep you guys updated with more feedback on wet traction and all.
I worked late today but I will post some pics tomorrow, she is a little dirty but “I like her when she is dirty”
sppb is offline   Reply With Quote
Old 03-08-2008, 10:52 AM   #13
Senior Member
 
sppb's Avatar
 
Join Date: Mar 2007
Location: Ogdensburg, NJ
Posts: 1,738
finally got new rubber

It’s raining outside but I took a pic anyway
sppb is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-08-2008, 01:17 PM   #14
Senior Member
 
HeminatorTom's Avatar
 
Join Date: Feb 2007
Location: Austin, AR
Posts: 3,730
finally got new rubber

Looks as good as my new Toyo 305/50/20 tires. I love the Toyos.
HeminatorTom is offline   Reply With Quote
Old 03-09-2008, 01:39 PM   #15
Senior Member
 
IWANTMORE's Avatar
 
Join Date: Aug 2006
Location: Mt. Pleasant, SC
Posts: 6,533
finally got new rubber

IWANTMORE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:29 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.