#$@!#%!@ Brake light socket - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Running Gear | Brakes, Wheels and Tires

Reply
 
Thread Tools Display Modes
 
Old 10-10-2011, 09:03 AM   #1
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
Right brake light has been a pain in the backside on this truck for as long as I've owned it. I have to to take it apart and fill the socket with dielectric grease and it works for a while and then I'll have to do it again. Sometimes it lasts for quite a while, but as luck would have it, when I'm trying to sell the truck, I've had to take it apart 3 times in the last week.

Anyone got any ideas to keep this thing making good contact?

__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-10-2011, 09:03 AM   #2
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
Right brake light has been a pain in the backside on this truck for as long as I've owned it. I have to to take it apart and fill the socket with dielectric grease and it works for a while and then I'll have to do it again. Sometimes it lasts for quite a while, but as luck would have it, when I'm trying to sell the truck, I've had to take it apart 3 times in the last week.

Anyone got any ideas to keep this thing making good contact?
__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Old 10-10-2011, 09:25 AM   #3
Senior Member
 
TooCool's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 1,108
Just had a problem with mine throwing the lamp out light on intermittedly.When i checked all the light's i could'nt find any out.Decieded to start with the tail light's.Found the brake light bulb on the D/S had a dark spot on it and the contact's where dark also.(indicating the bulb had got hot)Replaced the bulb,cleaned all bulb's contact's and socket's contact's.Also bent the finger's in on the socket contact's.Problem solved.So try cleaning all the contact's with sandpaper(bulb and socket) and take a small screwdriver bend the finger's in on the socket.(if they got hot they tend to spread) Put your dielectric grease in and you should be good to go.
TooCool is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-10-2011, 09:39 AM   #4
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
Been there, done all of that. I tried pinching the socket tighter several times. Cleaning the sockets is where I started the escapade. I'll give it one more go tonight, take it in the house and see if I can't get the socket to tighten up a bit more.

My bulbs are never burnt out. This particular one just wiggles itself out apparently and it's ALWAYS the same one. I'm about ready to get out the aluminum foil.
__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Old 10-10-2011, 10:19 AM   #5
Senior Member
 
TooCool's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 1,108
Lori are you just getting a lamp out light or is the light not coming on? If the light's not coming on it's probably the contact's.There is a plastic stop inbetween the contact's that will only allow the tab to be bent in so far.Try taking a pair of needle nose plier's to the top of the contact's to get them closer together.
TooCool is offline   Reply With Quote
Old 10-10-2011, 11:03 AM   #6
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
Quote:
Originally posted by TooCool:
Lori are you just getting a lamp out light or is the light not coming on? If the light's not coming on it's probably the contact's.There is a plastic stop inbetween the contact's that will only allow the tab to be bent in so far.Try taking a pair of needle nose plier's to the top of the contact's to get them closer together.
Yes, I've done that. Yes, the lamp out indicator is on and the light does not come on when the brakes are applied. Sometimes it jumps around while I'm driving and that stupid indicator goes off and on along with the DING, DING, DING, DING, DING, DING... that goes with it. I hate the dinging more than the issue itself!
__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Old 10-10-2011, 11:14 AM   #7
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
And thank you for all the suggestions. I'm greatful for the responses. I should have spelled out a little better what I've done over the past few years to try to resolve this issue.
__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Old 10-10-2011, 11:41 AM   #8
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
Aluminum foil and electrical tape.
__________________

RANCHER is offline   Reply With Quote
Old 10-10-2011, 12:34 PM   #9
Senior Member
 
TooCool's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 1,108
Lori i don't know if your aware of it,but there is a known issue with the circut board's on the tail light's of the 03 truck's.Has also been seen on some 04's and 05's.Thought this might be my issue so i called to find out what they cost.At Autozone they are $20.This might be the solution to your problem weather it's the board or the contact's.
TooCool is offline   Reply With Quote
Old 10-10-2011, 01:19 PM   #10
Senior Member
 
Lori's Avatar
 
Join Date: Aug 2006
Location: Kansas
Posts: 2,352
Quote:
Originally posted by TooCool:
Lori i don't know if your aware of it,but there is a known issue with the circut board's on the tail light's of the 03 truck's.Has also been seen on some 04's and 05's.Thought this might be my issue so i called to find out what they cost.At Autozone they are $20.This might be the solution to your problem weather it's the board or the contact's.
WOW, thanks! I'll have to search their site for the part number.
__________________
Lori

'03 1500 Ram Quad Cab, 4 x 4 Laramie package - Beautiful Black - Umm, does Synth. Oil Count as a Mod?
Flowmaster 40 - GRRRR. 3rd Strike CAI.... hmm.... what's next?

My '03 Truck 2006-2011/My New Challenger



http://www.lovemyoldhome.com
Lori is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.