ABS hydraulic unit question. - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Running Gear | Brakes, Wheels and Tires

Reply
 
Thread Tools Display Modes
 
Old 09-14-2011, 09:39 AM   #1
Junior Member
 
Join Date: Sep 2011
Location: Tonica, IL
Posts: 1
Today my abs & brake light came on. Have xcellent brakes with pull pedal. However the ABS hydraulic unit runs constantly. While truck is running or not. At a loss, any help would be appreciated.

Truck is an '04 2500 HD Ram 4x4 SLT & a Hemi.

hemi4camping is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-14-2011, 09:39 AM   #2
Junior Member
 
Join Date: Sep 2011
Location: Tonica, IL
Posts: 1
Today my abs & brake light came on. Have xcellent brakes with pull pedal. However the ABS hydraulic unit runs constantly. While truck is running or not. At a loss, any help would be appreciated.

Truck is an '04 2500 HD Ram 4x4 SLT & a Hemi.
hemi4camping is offline   Reply With Quote
Old 09-14-2011, 10:49 AM   #3
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
__________________
2003, Std. SWB, SLT, 20", 4:56 gear, AFE CAI, Superchip, 6.1 cam, 6.1 heads, Manley springs, retainers, pushrods, Edelbrock Hedders, 195 T-Stat, 8.2 Taylor, AEM, Power Wire, ARC-1,Amsoil Everything, and more. Veni Vidi Vici

HTC.com Titan Killer Club

Member # 17



Superjay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-15-2011, 06:28 PM   #4
The Original Bee
 
HemiSuperBee's Avatar
 
Join Date: Jul 2005
Location: DFW, Texas
Posts: 2,071
Definitely sounds like an electrical issue, but without a DTC will be tough to diagnose. You would need to find a scan tool with an ABS reader to get the code, Superchips or regular engine DTC reader won't do it.

If I had to guess sounds like ABS Actuator or ECM.
__________________
********AWARDS********

9 Best of Show
21 First Place
3 Class Awards
2 Truck of the Month
HTC Best Dressed Engine

**********************
HemiSuperBee is offline   Reply With Quote
Old 10-17-2011, 03:22 AM   #5
Senior Member
 
5SpeedHemi's Avatar
 
Join Date: Jun 2004
Location: Nova Scotia, Canada
Posts: 4,713
And even after using a scan tool and getting a code or codes it wont bring you directly to the problem nesessarly can be many different reasons for the same symptoms. if you don't find the problem fairly quickly then it could be one of those bitchy hair pulling ones. if your truck is under warranty bring it in
__________________
2003 Silver Ram 2500 Moose SLT QC/LB 4x4 | NV4500-HD 5Speed Manual trans | Tow pkg | Centerline dual friction clutch| 3.73 LS |Borla dual catback |Bilstein Shocks| Billet Grill | 15% Win Tint | Bushwacker color matched flares| Pwr adjustable petals |Superchip| Mopar wheel liners |Ramhammer intake| Mopar alum fuel door | MSD Blaster coils & 8.5 ignition wires |SS nerf bars | Chrome ext handles | Atm graphite tails |Silverstar bulbs| Hurst alum T handle shifter| B&D Short throw Shift kit|

5SpeedHemi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.