Wobble under acceleration - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Suspension, sway bars, lowering and lift

Reply
 
Thread Tools Display Modes
 
Old 04-12-2015, 08:21 PM   #1
Junior Member
 
Join Date: Jan 2015
Location: Ennis
Posts: 3
Wobble under acceleration

My 2014 R/T has recently developed some exessive side to side body sway during hard acceleration. And it just seems to intensify once it starts. The truck does have a dealer installed 2-4 drop, but i didn't experience this before. Anyone else experiancing anything like this?

REDRAM is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-12-2015, 08:27 PM   #2
Senior Member
 
hemiram13's Avatar
 
Join Date: Apr 2014
Location: Casselberry, FL
Posts: 648
Garage
I have a 2013 express RCSB that's stock suspicion wise and I also work for a dealer. At the dealer stand point I'm more than sure that the dealer would blame the wobble due to your suspension alterations. Did you have your beast aligned after you had the lowering kit installed?
__________________
2013 RC Express HEMI

hemiram13 is offline   Reply With Quote
Old 04-12-2015, 10:35 PM   #3
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,273
Garage
Have the alignment checked for sure. 2wd 1500 trucks normally don't get odd wobble issues like that unless something's way out of wack
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-13-2015, 10:23 AM   #4
Senior Member
 
HemiFun05's Avatar
 
Join Date: Jul 2007
Location: College Station, Texas
Posts: 13,175
Thumbs up

REDRAM

Looks like your #1 Post so:





__________________
HemiFun05
'Doc'
"Christians Aren't Perfect - We Are Forgiven"
HemiFun05 is offline   Reply With Quote
Old 04-13-2015, 02:33 PM   #5
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,664
Garage
__________________

SUPER BEE is offline   Reply With Quote
Old 04-13-2015, 03:02 PM   #6
john
 
wolf_with_the_red_rose1969's Avatar
 
Join Date: Jul 2014
Location: sylva
Posts: 1,084
Garage
Send a message via Yahoo to wolf_with_the_red_rose1969
:Kneel2Hem i:
__________________
wolf_with_the_red_rose1969 is offline   Reply With Quote
Old 04-13-2015, 03:30 PM   #7
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,102
Garage
The newer models with coils springs might be loading and unloading causing the rear to move back and forth. I understand as they go up and down they also go side to side.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 04-13-2015, 04:13 PM   #8
Matt
 
MANual_puller's Avatar
 
Join Date: Mar 2014
Location: Vinton
Posts: 2,652
Garage
Some tire compounds don't squeal. Are you sure you aren't just spinning? I couldn't imagine a 4 link suspended rear end moving around too much unless something is broken.....
__________________
2011 Ram 2500 ST 4x4, 5.7L Hemi, crew cab, short box, 4:10 gear ratio with rear LSD, 180 amp alternator, tow mirrors w/ puddle and signal lamps, popular options group, carpet deleted, Ranch Hand front bumper, 9500# winch, pair of 100w KC lights, Magnum RT steps, Line-x sprayed bedliner, stampede o/e style fender flares, Ram branded oversize rubber mud flaps, stampede smoked bug deflector, Dee Zee toolbox

MANual_puller is offline   Reply With Quote
Old 04-13-2015, 04:29 PM   #9
Junior Member
 
Join Date: Jan 2015
Location: Ennis
Posts: 3
I am making the assumption that the alignment was done after the drop install. Front tire wear looks good so far.
REDRAM is offline   Reply With Quote
Old 04-13-2015, 04:31 PM   #10
Junior Member
 
Join Date: Jan 2015
Location: Ennis
Posts: 3
The two times this has happened, I was already up to around 70 or so, dont think it was breaking loose.
REDRAM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.