Suspension squeak - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Suspension, sway bars, lowering and lift

Reply
 
Thread Tools Display Modes
 
Old 07-22-2006, 01:00 PM   #1
 
Join Date: May 2006
Posts: 103
Suspension squeak

I have a question, I think I know the answer but any input would help... The passenger side (front) has a slight kinda squeaking sound, like the rubber in there or something needs greased, is there a place to shoot some grease in there, with a grease gun?

This thing has a HEMI! is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-23-2006, 11:43 AM   #2
 
Join Date: Feb 2006
Posts: 1,683
Suspension squeak

i got kinda the same thing. When I decelerate (not braking) or start off from a slow start I get alot of squeling or squeaking, its starting to get bad. I have been all through the front end and have found nothing that needed greasing. I am thinking its my bearings in the hubs that need to be repacked. I dont know though. I am sure someone will say something soon
HARDKILLINPETE is offline   Reply With Quote
Old 11-07-2006, 12:41 PM   #3
Senior Member
 
otnielarencibia's Avatar
 
Join Date: Feb 2006
Location: Pompano, FL
Posts: 1,413
Suspension squeak

I am too having a squeaking noise coming from the front....it sounds like some old motor mounts...or the bearings in the hub. Does anyone know what it could be? Please help us. Thanks in advance.
otnielarencibia is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-09-2006, 08:08 AM   #4
Senior Member
 
otnielarencibia's Avatar
 
Join Date: Feb 2006
Location: Pompano, FL
Posts: 1,413
Suspension squeak

Does anyone have a guess?
otnielarencibia is offline   Reply With Quote
Old 11-12-2006, 03:00 PM   #5
 
Join Date: Jul 2004
Posts: 303
Suspension squeak

If its your hub it will be more of a chatter not a squeak. I would look at your shock bushings. grease em up and it might work mine were squaking and my hub went bad so i've heard some sounds. I spent nearly 1000 on this truck in 3 weeks.
04hemipower is offline   Reply With Quote
Old 11-15-2006, 05:26 PM   #6
 
Join Date: Feb 2005
Posts: 69
Suspension squeak

I have the same thing in my wifes 05 Ram 1500 QC 4x4. It sounds like a chirping sound to me. It doesnt do it all the time either. Sometimes you will hear it every time you drive it for a week. Then sometimes you will not hear it for a couple of days. I have had it at the dealer like 10 times over the past year and a half and of course they cannot duplicate it. To me it sounds like a bad shock or sway bar end link.

I am real close to ordering new Rancho RS 5000 shocks for the damn thing. I am in the process of looking for replacement sway bar end links. If it fixes it then I will write a letter to Chrysler. I dont know what else to do. There are no TSBs or anything about it.


I also have an intermittant groan like brakes hanging up you use them. Only happens after you brake then accelerate. They cant duplicate that either.

I am also thinking about getting rid of the damn thing if it keeps it up
skeezer450 is offline   Reply With Quote
Old 12-01-2006, 06:43 AM   #7
\71 Challenger
Guest
 
Posts: n/a
Suspension squeak

I have the annoying squeak also...especially noticeable on dirt roads...I'm wondering if it could be from the torsion bar ends.
  Reply With Quote
Old 12-03-2006, 06:17 PM   #8
Senior Member
 
Raminator's Avatar
 
Join Date: Jul 2005
Location: Waco, TX
Posts: 180
Suspension squeak

I have the same noise, defintely sounds like a bad bushing somewhere, from the front passenger side. But, I also hav a slight popping noise that sounds like a HUB bearing is popping. I only have 22K miles and thinking of letting it go for a bit before taking it in, just to make sure that they have no problem finding the issue. But, it seems weird because some days it seems fine, but some days it almost drives me nuts. Not sure what to think.
Raminator is offline   Reply With Quote
Old 12-08-2006, 01:46 PM   #9
Senior Member
 
CentralTexHemi's Avatar
 
Join Date: Jun 2005
Location: Woodway (Waco), Texas
Posts: 8,246
Suspension squeak

I had the same noise right after I bought the truck, after 3 trips to Wako dodge, I took it to Temple dodge and the figured out it was the hood, the adjustable supports were just down enough to not meet flush with the hood when it was closed and was causing the squeeking noise, felt really silly.
CentralTexHemi is offline   Reply With Quote
Old 12-08-2006, 06:55 PM   #10
 
Join Date: Feb 2005
Posts: 69
Suspension squeak

Quote:
quote:Originally posted by CentralTexHemi:
I had the same noise right after I bought the truck, after 3 trips to Wako dodge, I took it to Temple dodge and the figured out it was the hood, the adjustable supports were just down enough to not meet flush with the hood when it was closed and was causing the squeeking noise, felt really silly.
Mine finally is fixed and it was the same problem as central Texas HEMi. The first time they took it out they heard it and lubed something on the torsion bars. The service guy came in and said it fixed. My wife said lets go for a ride and the noise was still there so they went back in and found those hood striker thingys out of adjustment. He adjusted them and lubed them and the noise is finally freakin gone...only took like 6 trips to the dealer for them to finally hear it.
skeezer450 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.