Ride height difference - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Suspension, sway bars, lowering and lift

Reply
 
Thread Tools Display Modes
 
Old 10-03-2012, 04:25 PM   #1
Senior Member
 
Bohica's Avatar
 
Join Date: Nov 2009
Location: Central NJ
Posts: 108
Last summer (2010) I had installed Bilstein 5100 series shocks in the front. I had them installed at the max height lift and now the driver's side is a half inch lower than the passengers side. The spring seat looks fine and i have no idea what could have caused this. Anyone out there have an idea of what happened? And I have never been off road or abused the truck in any way.

__________________
07 SLT Quad Cab
Plenty of 'tasteful' mods
Bohica is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-03-2012, 04:25 PM   #2
Senior Member
 
Bohica's Avatar
 
Join Date: Nov 2009
Location: Central NJ
Posts: 108
Last summer (2010) I had installed Bilstein 5100 series shocks in the front. I had them installed at the max height lift and now the driver's side is a half inch lower than the passengers side. The spring seat looks fine and i have no idea what could have caused this. Anyone out there have an idea of what happened? And I have never been off road or abused the truck in any way.
__________________
07 SLT Quad Cab
Plenty of 'tasteful' mods
Bohica is offline   Reply With Quote
Old 10-03-2012, 04:42 PM   #3
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,265
Garage
If the snap ring for height adjustment on the shock is on the same spot you had originally had it then The coil spring is sagged and needs to be changed shocks them self only control spring action they don't support any actual load
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-03-2012, 04:53 PM   #4
Senior Member
 
Bohica's Avatar
 
Join Date: Nov 2009
Location: Central NJ
Posts: 108
The snap ring is still in the original location and I was thinking that it had something to do with the spring itself. Not sure what else it could be since nothing seems out of the ordinary. I'm probably going to do some further inspection tomorrow if the weather allows me to. Thanks for the help.
__________________
07 SLT Quad Cab
Plenty of 'tasteful' mods
Bohica is offline   Reply With Quote
Old 10-24-2012, 02:13 AM   #5
Farrrrrr East Coast
 
NewfieBullet's Avatar
 
Join Date: Apr 2008
Location: Newfoundland Canada
Posts: 3,764
Garage
not sure about an 07 but mine on the drivers side its a half in lower anyway always has been i blame it on the gas tank
__________________
Check Out My Garage For Mods and Pics, There's A Few :P

NewfieBullet is offline   Reply With Quote
Old 10-24-2012, 11:19 AM   #6
Senior Member
 
Bohica's Avatar
 
Join Date: Nov 2009
Location: Central NJ
Posts: 108
Turns out that I had another dumb moment(yes, once again haha). It happened to be my tire that was worn down, and after rotating them the difference followed the tire. I'll probably replace them soon anyways, but I really appreciate all the help that this forum has provided time and time again.
__________________
07 SLT Quad Cab
Plenty of 'tasteful' mods
Bohica is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.