Burning smell? - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Suspension, sway bars, lowering and lift

Reply
 
Thread Tools Display Modes
 
Old 04-16-2005, 03:43 PM   #1
Senior Member
 
jlhram's Avatar
 
Join Date: Aug 2004
Location: Roanoke, Texas
Posts: 1,812
Burning smell?

maybe this is a stupid ?,but I have changed a lot of brakes and this has NEVER happened. I turned my rotors and put on a set of the hawk performance pads. While doing the break-in procedure they recommend I noticed a very strong burning smell coming from the brakes. Any one else have this happen?, is it something I should worry about? Too soon to tell but my initial feeling is the pads help.

jlhram is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-16-2005, 07:08 PM   #2
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
Burning smell?

ohhhh...never liked anything that had to do with breaks smelling.. Be sure to let us know if you figure out what it is...
BTW...Hi Jim!
RANCHER is offline   Reply With Quote
Old 04-16-2005, 07:10 PM   #3
*Damn*its*gotta*Hemi*
Guest
 
Posts: n/a
Burning smell?

I put new hawk pads on my wifes Expedition but I didn't smell anything after I did the break-in. Did the rotors have any lubricant left on them that could cause the burning smell? Have you noticed it since the inital break-in?
  Reply With Quote
Sponsored Links
Advertisement
 
Old 04-17-2005, 10:30 AM   #4
Senior Member
 
jlhram's Avatar
 
Join Date: Aug 2004
Location: Roanoke, Texas
Posts: 1,812
Burning smell?

Thanks for the reply guys, Brakes seem to be fine, work great and I haven't noticed the burnt smell from before. Who knows. I'll keep an eye on them and let you know. Was just wondering if it was normal for break in, they do call it burnishing the brakes.
BTW...What's up Rancher
jlhram is offline   Reply With Quote
Old 04-17-2005, 11:31 AM   #5
 
Join Date: Oct 2004
Posts: 1,012
Burning smell?

Quote:
quote:Originally posted by *Damn*its*gotta*Hemi*:
Did the rotors have any lubricant left on them that could cause the burning smell?
that's kinda what i was wondering. some new rotors are shipped with a lube on them that needs to be wiped off. but if they were turned......

BTW..hey, jim. should have my programmer by June. and i got traction now. you're going down! sorry...Rancher's not sure if he's going so i gotta talk trash to somebody
SLINGER is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.