Stumped/help - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > 3rd Generation Ram | 2003 - 2008

Like Tree6Likes
  • 3 Post By Redtruck-VA
  • 3 Post By ric3xrt
Reply
 
Thread Tools Display Modes
 
Old 01-11-2019, 09:50 PM   #1
Junior Member
 
Join Date: Jan 2019
Posts: 2
Stumped/help

Brand-new to the forum/been reading for years though.

I have a 2004 Dodge ram 1500/5.7 Quad cab

Part one : I bought the truck three years ago drove it for roughly 10,000 miles when the back end of the crank snapped.... Bought a new steel crank at the motor completely redone. Drove the new motor roughly 8000 miles before it developed a rear main seal leak/after towing a trailer up over a mountain pass I realized my rear main seal had been leaking in the engine developed a knock.

Part two: I had this motor once again sent off for inspection/it threw a rod most likely because of me not paying attention to the oil leak. At this point I ordered and rebuilt motor with a five-year warranty/100,000 miles ..... Within 20 miles of this new motor I blew a rear main seal once again..... The motor was under warranty .... The staff said the engine was most likely junk and get to a garage.... Upon test driving it for the garage a loud bang/boom sounded under the hood.... Blue my oil cap off in oil everywhere...

They sent me a long block replace motor number two.... This time we replace the EGR valve/PVC valve ,new coils, new spark plugs, new wires.

The truck was running really good for about 30 miles until I got on the highway.... It developed a lot of vibration when the truck would try to settle into overdrive (rpm's 3000-- D accelerating from 2000-1500) the vibration would get bad until I stepped on the gas and the vibration would go away (rpm's would have to be over 2500) (as soon as the RPMs dipped back between 1500 and 2000 RPMs the vibration would come back.

I pulled over at the nearest gas station to slap my forehead in disgust as I was leaking oil from that same spot once again(rear main seal)

I live in a rule area of Vermont.... Finding a good mechanic is difficult..... Three motors/three rear main seal's (including one end of the crank snapped) and my looking at this problem all wrong? Does this have something to do with my transmission or torque converter? Maybe the rear end? I'm about ready to just jump this truck.... Even though I swore I would never buy new again fixing these old trucks up and getting them to run correctly/I'm about ready to just give up .... Any thoughts on what direction I should go IN...WHAT COULD THIS BE?

VTgreenmtman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-11-2019, 09:55 PM   #2
Junior Member
 
Join Date: Jan 2019
Posts: 2
Update: scan the truck for codes as the engine light was on...P0300/P0306 PO151/PO152 PO157 ...... if I drive this truck around town only going 35 miles an hour it seems to be okay.... The minute I take it out on the highway the vibration in the stuttering just comes back.
VTgreenmtman is offline   Reply With Quote
Old 01-11-2019, 10:17 PM   #3
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,679
Garage
__________________

SUPER BEE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-12-2019, 03:27 AM   #4
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 19,172
Garage
Three engines with the same problem? What rotating part has been used on all three? That would most likely be the torque converter. Sounds like you got the most miles out of it until you made that hard trailer pull over the mountain. Then you have had a vibration ever since breaking engines. I would stop driving the truck immediately and replace the torque converter. Welcome to the forum.
CavRam, SUPER BEE and ric3xrt like this.
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1956 Jeep Willys Pickup Hemi powered "Street Rod project"

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 01-12-2019, 07:26 AM   #5
Queen Kima - Whemi BOD
 
Mrs.Studmuffin's Avatar
 
Join Date: Sep 2005
Location: Denison, TX
Posts: 10,294
__________________
.
Not everyone can be queen.....there has to be someone standing on the curb to wave as I go by.
.

Mrs.Studmuffin is offline   Reply With Quote
Old 01-12-2019, 10:46 AM   #6
Senior Member
 
ric3xrt's Avatar
 
Join Date: Dec 2016
Location: Trumbauersville
Posts: 2,673
Garage
I agree with Redtruck(AKA Greg) something is a miss in the trans or converter putting undue thrust pressure on the crank. these engine are neutral balance so that rules out a weigh falling off the flex plate....If I had to bet money on it it's in the converter.
Redtruck-VA, CavRam and SUPER BEE like this.
__________________
05 GTxtreme [email protected] , Not bad for a 392Ci NA 4400 lbs truck ,
04 SLT ...Give me some time I just bought it.
ric3xrt is offline   Reply With Quote
Old 01-13-2019, 07:38 AM   #7
Stu
 
Join Date: Oct 2009
Location: FL
Posts: 20,449
Garage
Welcome to HTC.

Also agree with Greg and Rick on the converter. You could also have the flex plate checked to see if it runs true. A bad vibration can damage other things also.

Good luck and keep us informed.




.
Ghost03hemi is offline   Reply With Quote
Old 01-13-2019, 09:56 AM   #8
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,302
Garage
Deff converter or trans issue there solve that quickly
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 01-15-2019, 11:39 AM   #9
Gold-Member
 
kcd1369's Avatar
 
Join Date: Oct 2004
Location: Brandon, FL
Posts: 4,055
Garage
with them

to HTC!
__________________
05 1500 SLT Quad Black on Black | Pace Setter Long Tubes | Magna Flow Cat Back | Doug's Electric Cutout | Custom Ram Air Hood | Spyder LED Tails | Spec-D Black Projectors W/Halos | Flex-A-Lite E-Fan |Jet 180 Stat | K&N CAI | 20 inch wheels | Comp 268 Cam W/6.1 push rods and springs | Diablo Trinity | Custom Tune by Charged392.





kcd1369 is offline   Reply With Quote
Reply

Tags
o2 codes, rear main, vibration

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 05:27 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.