Fuel problems.. - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > 3rd Generation Ram | 2003 - 2008

Reply
 
Thread Tools Display Modes
 
Old 09-23-2015, 06:43 PM   #1
Junior Member
 
Join Date: Sep 2015
Location: Elizabethton
Posts: 9
Fuel problems..

Truck acts like its starving for fuel. Starts and idles for about 2 seconds then you smell gas. Have fuel pressure up to at least the fuel rail. Already replaced throttle body, evap purge valve, idle air control, cam sensor and crank sensor, ECM. No codes.

Clones87 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-2015, 06:46 PM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,168
Garage
Smell raw fuel leaking or thru exhaust?
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-23-2015, 06:47 PM   #3
Junior Member
 
Join Date: Sep 2015
Location: Elizabethton
Posts: 9
Through exhaust
Clones87 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-2015, 06:50 PM   #4
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,168
Garage
If you smell fuel then it's likely not stArving for fuel. Do you have access to a scanner? Also if you drive it and floor the gas does it just have no power or does it sound likes it popping?
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-23-2015, 06:54 PM   #5
Junior Member
 
Join Date: Sep 2015
Location: Elizabethton
Posts: 9
Just idles about 5-10 seconds. Already been scanned no problems.
Clones87 is offline   Reply With Quote
Old 09-23-2015, 06:55 PM   #6
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,824
Garage
Quote:
Originally Posted by Clones87 View Post
Truck acts like its starving for fuel. Starts and idles for about 2 seconds then you smell gas. Have fuel pressure up to at least the fuel rail. Already replaced throttle body, evap purge valve, idle air control, cam sensor and crank sensor, ECM. No codes.
Is this a 4.7?
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 09-23-2015, 06:58 PM   #7
Junior Member
 
Join Date: Sep 2015
Location: Elizabethton
Posts: 9
5.7
Clones87 is offline   Reply With Quote
Old 09-23-2015, 06:58 PM   #8
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,168
Garage
Oh so it won't run long at all then shuts off. There's something wrong here and a scanner is the only way to figure this out from this point I believe. Not
For
Pulling codes but making sure all sensors and what not are ready corectly.
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 09-23-2015, 07:00 PM   #9
Junior Member
 
Join Date: Sep 2015
Location: Elizabethton
Posts: 9
When we had it scanned all the sensors were reading correctly and showed spark advance was fine
Clones87 is offline   Reply With Quote
Old 09-23-2015, 07:03 PM   #10
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,168
Garage
This is weird then. If all sensors are reading good but it still won't run and the little it does run its super rich. What is the actual fuel pressure at the rail?
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.