air conditioning problems 2005 ram 2500 - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > 3rd Generation Ram | 2003 - 2008

Like Tree1Likes
  • 1 Post By Lil Red 78
Reply
 
Thread Tools Display Modes
 
Old 05-07-2018, 09:08 PM   #1
Junior Member
 
Join Date: Sep 2016
Location: Boston
Posts: 12
air conditioning problems 2005 ram 2500

I have a 2005 RAM 2500 SLT with 86k miles. hemi slt 4X4 QUAD

My Ac Blows cool air not cold on hot days. I have added a can of freon but still the same results.
front cold air IS about 50 degrees. All the vents work top and bottom.

WHEN i first got the RAM it was so cold on long drives it would freeze up and would have to pull over so it would un freeze.
I was able to find a bulletin on a fix for the freezing was to add a resistor in series with a wire on the ac controls to slow down the compressor to cycle on off more. That helped on the long drives.

But getting in the RAM now and just seems it could be colder.
The compressors stays on pretty much not much cycling.
Added 1 can of freon not much difference in temperature .
I measured with a digital thermometer and at the vents about 50 degrees.

Checked pressure with gauges and the low side about 37 and when compressor kicks in goes down to about 22 then back up to 37. High side was around 200+

Just cant seem to get the ac to get colder!!!!!!!!!!!!!!

Any suggestions??

dss56 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2018, 04:25 AM   #2
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
Is the condenser fan working when the compressor is on?

If the fan is working and the pressure are low like that the charge is low and I suggest taking to a shop to find the leak the evap core is very common leak point on the Rams. The system may also just need a good vacuum pulled on it air and moisture can make the system run warmer than normal
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Old 05-08-2018, 07:57 AM   #3
Senior Member
 
xtremwlr's Avatar
 
Join Date: May 2017
Location: Tucson
Posts: 402
You sure the recirc door hasn't broken and is blocking airflow from the HVAC fan in the cab?
xtremwlr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2018, 09:30 AM   #4
John
 
SUPER BEE's Avatar
 
Join Date: Feb 2014
Location: Meridian, MS
Posts: 3,645
Garage
__________________

SUPER BEE is offline   Reply With Quote
Old 05-08-2018, 01:58 PM   #5
David
 
ATXHEMI's Avatar
 
Join Date: Mar 2011
Location: Austin, Texas
Posts: 2,225
Garage
Quote:
Originally Posted by xtremwlr View Post
You sure the recirc door hasn't broken and is blocking airflow from the HVAC fan in the cab?
This happened on my 05.
__________________
BV Heads-Greene Racing Cammed & Tuned.



ATXHEMI is offline   Reply With Quote
Old 05-08-2018, 02:10 PM   #6
Senior Member
 
xtremwlr's Avatar
 
Join Date: May 2017
Location: Tucson
Posts: 402
Quote:
Originally Posted by ATXHEMI View Post
This happened on my 05.
Mine too, that's why I asked.

Broken recirc door, laying on top of the blower fan.



Fixed door.

xtremwlr is offline   Reply With Quote
Old 05-12-2018, 09:10 PM   #7
Junior Member
 
Join Date: Sep 2017
Location: Sunbright
Posts: 10
I had a similar problem. I started by throwing the cheaper parts at it first, but there are so many parts involved. I then had my system evacuated and the proper am put in. It's not a good idea to just start putting cans of freon in since it will probably lead you back to the start. Mine worked great for 2 weeks. Then I got an evaporator temperature sensor to put in the core and as I started taking things apart I found the climate control module not plugged in all the way. Corrected and works perfectly. I got lucky. Apparently it had the recall or 3rd party fix on the doors and they did everything but plug it up properly. I have thrown a lot of money at Mopars before and it usually ended up being simple.
xtremwlr likes this.
Lil Red 78 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 09:28 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.