Trouble with rough idle - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 05-09-2012, 06:12 AM   #1
Junior Member
 
WagzHemi4x4's Avatar
 
Join Date: Apr 2012
Location: Luxemburg WI
Posts: 6
Hey guys hoping some one can shed some light on this problem, i have a 03 Ram 2500 5.7 Hemi, i got a check engine code the other day P0300 random misfire code and i looked up what it could be and got a laundry list of things. I have replaced pretty much everything on that list spark plugs, wires, coil packs, pcv valve, camshaft position sensor, fuel vapor canisters, fuel vapor leak detection pump and fuel pressure regulator. the only things i have not done is o2 sensor, fuel injectors and valve springs but i dont know if it is any of these parts that i have not changed yet. Im into this fix $475 and still having the problem. To start the truck i have to hold my foot down on the pedal just a bit to get it started once its started i have to keep it above 1500rpms or it just dies. Also i don't think its the valve springs because there should be loud ticking coming from the engine when running. If some one could help shed some light on this problem so i can have my truck back it would be greatly appreciated thank you so much.

WagzHemi4x4 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-09-2012, 06:12 AM   #2
Junior Member
 
WagzHemi4x4's Avatar
 
Join Date: Apr 2012
Location: Luxemburg WI
Posts: 6
Hey guys hoping some one can shed some light on this problem, i have a 03 Ram 2500 5.7 Hemi, i got a check engine code the other day P0300 random misfire code and i looked up what it could be and got a laundry list of things. I have replaced pretty much everything on that list spark plugs, wires, coil packs, pcv valve, camshaft position sensor, fuel vapor canisters, fuel vapor leak detection pump and fuel pressure regulator. the only things i have not done is o2 sensor, fuel injectors and valve springs but i dont know if it is any of these parts that i have not changed yet. Im into this fix $475 and still having the problem. To start the truck i have to hold my foot down on the pedal just a bit to get it started once its started i have to keep it above 1500rpms or it just dies. Also i don't think its the valve springs because there should be loud ticking coming from the engine when running. If some one could help shed some light on this problem so i can have my truck back it would be greatly appreciated thank you so much.
WagzHemi4x4 is offline   Reply With Quote
Old 05-09-2012, 01:59 PM   #3
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,899
Garage
I have reponded to this thread twice and both times my reply disappeared. Anyway my guess is you have a broken valve spring. I recommend pulling the valve covers and carefully check the springs. Good luck...
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-09-2012, 02:59 PM   #4
Junior Member
 
WagzHemi4x4's Avatar
 
Join Date: Apr 2012
Location: Luxemburg WI
Posts: 6
i will pull the valve covers and check them but im not shure if it is the valve springs because i talked to some one i know that used to be a mechanic and he did say that if i did have broken valve springs that i should be hearing a loud ticking from the rockers having to much play. also i have confirmed that its not just one cylinder misfiring.
WagzHemi4x4 is offline   Reply With Quote
Old 05-09-2012, 03:40 PM   #5
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,899
Garage
Quote:
Originally posted by WagzHemi4x4:
i will pull the valve covers and check them but im not shure if it is the valve springs because i talked to some one i know that used to be a mechanic and he did say that if i did have broken valve springs that i should be hearing a loud ticking from the rockers having to much play. also i have confirmed that its not just one cylinder misfiring.
I generally agree with your mechanic, however doesn't take much on the hemi to drop a push rod off the rocker and not hear it. Not trying to make excuses but I would check for a broken spring as 03/04 have known valve spring problems. A general misfire code only indicates the engine idle is changing speed outside the set PCM parameter. If it is calling out a specfic cylinder, it may well be injector/coil related as there is no other way to sense specific misfires. good luck..
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 05-09-2012, 03:40 PM   #6
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
Ck springs/run compression test!
__________________
2003, Std. SWB, SLT, 20", 4:56 gear, AFE CAI, Superchip, 6.1 cam, 6.1 heads, Manley springs, retainers, pushrods, Edelbrock Hedders, 195 T-Stat, 8.2 Taylor, AEM, Power Wire, ARC-1,Amsoil Everything, and more. Veni Vidi Vici

HTC.com Titan Killer Club

Member # 17



Superjay is offline   Reply With Quote
Old 05-10-2012, 05:25 AM   #7
Junior Member
 
WagzHemi4x4's Avatar
 
Join Date: Apr 2012
Location: Luxemburg WI
Posts: 6
ok when i check the valve springs if i find any broken is there a way to change them in the truck with out removing the heads?
WagzHemi4x4 is offline   Reply With Quote
Old 05-10-2012, 06:30 AM   #8
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,427
yes you can you need a overhead valve spring compresser tool like this
http://www.autobarn.net/lisle-59550.html
and you need to put compressed air in the cyl.to keep the valve up.
__________________
boedacres is offline   Reply With Quote
Old 05-10-2012, 08:21 AM   #9
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,899
Garage
I used this other style compressor which worked great. There are a couple members who manufacture this style on the side.

http://www.cranecams.com/produ...oduct_detail&p=25310
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is offline   Reply With Quote
Old 05-11-2012, 10:38 AM   #10
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,427
thats the one i wanted but couldnt find it at the time they work great.mine worked but its a pain in the butt
Quote:
Originally posted by Redtruck-VA:
I used this other style compressor which worked great. There are a couple members who manufacture this style on the side.

http://www.cranecams.com/produ...oduct_detail&p=25310
__________________
boedacres is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.