Replaced Spark plugs - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 02-01-2012, 08:43 PM   #1
Junior Member
 
Join Date: Nov 2008
Location: Alaska
Posts: 2
Gent's
I have a stock 04 1500 and have been having the cold weather starting problem with this winter. I choose to replace the spark plugs so I did and now Eng light is on. I forgot to plug in the electrical plug on the front of the air box so connected that and it didn't fix. Any ideas?? thanks
Travis

taildragger52 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-01-2012, 08:43 PM   #2
Junior Member
 
Join Date: Nov 2008
Location: Alaska
Posts: 2
Gent's
I have a stock 04 1500 and have been having the cold weather starting problem with this winter. I choose to replace the spark plugs so I did and now Eng light is on. I forgot to plug in the electrical plug on the front of the air box so connected that and it didn't fix. Any ideas?? thanks
Travis
taildragger52 is offline   Reply With Quote
Old 02-01-2012, 09:19 PM   #3
Board of Directors
 
HemiByrd's Avatar
 
Join Date: Aug 2005
Location: Draffenville, KY
Posts: 25,097
Garage


Do you have a way of reading trouble codes? If not any auto parts store will read them for you. From what you said it sounds like you disconnected the intake air temperature sensor in the air intake. If the computer threw a code it may clear up on it's own. Or you can reset any codes and the check engine light with a tuner or I think the parts store guys can.



By the way...you qualify for a Spark Master badge in your sig line.
__________________
'05 RCSB 1500 SLT 5.7 Hemi Ram - Airaid Long Snorkel UBI CAI - Taylor shorty wires - MSD Coil Packs Magnaflow y-pipe - Flowmaster 50HD - Superchips 3865 - Motive 4.56 gears - Detroit Truetrac - PML differential cover some good Karma 8.87 ET
HemiByrd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-02-2012, 04:30 AM   #4
Senior Member
 
FAhemiST's Avatar
 
Join Date: Jul 2006
Location: Ulster County, New York
Posts: 3,150
turn your key on/off 3 times, last time leaving it on, you'll see engine light code on dash
__________________
05 Black RC 4x4-Gone but not forgotten
11 White CC 4x4
FAhemiST is offline   Reply With Quote
Old 02-02-2012, 04:34 AM   #5
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
__________________

RANCHER is offline   Reply With Quote
Old 02-02-2012, 06:32 AM   #6
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
__________________
2003, Std. SWB, SLT, 20", 4:56 gear, AFE CAI, Superchip, 6.1 cam, 6.1 heads, Manley springs, retainers, pushrods, Edelbrock Hedders, 195 T-Stat, 8.2 Taylor, AEM, Power Wire, ARC-1,Amsoil Everything, and more. Veni Vidi Vici

HTC.com Titan Killer Club

Member # 17



Superjay is offline   Reply With Quote
Old 02-02-2012, 06:46 AM   #7
Gary
 
leadfoot's Avatar
 
Join Date: Jun 2007
Location: Staten Island, NY
Posts: 904
I bought a code reader at Harbor frieght tools cheap. Got alot of use out of it. Got a 2 year replacement warranty
__________________
Old ride
03 ram quad cab hemi

New ride
2013 Ram Crew Cab Sport
No Mods
leadfoot is offline   Reply With Quote
Old 02-02-2012, 10:48 AM   #8
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
For some reason, the "key dance" doesn't work for some/all '04s. I suspect that code will go 'way by itself.
__________________
MikeHTally is offline   Reply With Quote
Old 02-02-2012, 12:27 PM   #9
Senior Member
 
ArcticWolf's Avatar
 
Join Date: Aug 2006
Location: Castro Valley, CA
Posts: 4,159
Someone tell him which fuse to pull to reset the computer? This should do it, if not, the plugs may not be properly gaped and you maybe getting raw fuel down to your O2 sensors.

Check Engine is usually a smog sensor problem
__________________
......... Yea.. that California Old Fart has RETURNED!!!





ArcticWolf is offline   Reply With Quote
Old 02-02-2012, 02:19 PM   #10
Board of Directors
 
HemiByrd's Avatar
 
Join Date: Aug 2005
Location: Draffenville, KY
Posts: 25,097
Garage
The PCM fuse is #23 on the 04-05. Pull the fuse, turn the key to the on position and wait for all the chimes to quit. Then turn the key off and replace the fuse. That should do it, I think.
__________________
'05 RCSB 1500 SLT 5.7 Hemi Ram - Airaid Long Snorkel UBI CAI - Taylor shorty wires - MSD Coil Packs Magnaflow y-pipe - Flowmaster 50HD - Superchips 3865 - Motive 4.56 gears - Detroit Truetrac - PML differential cover some good Karma 8.87 ET
HemiByrd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.