I'm a dummy! - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 03-21-2012, 10:34 AM   #1
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,929
Garage
Just got back from overseas and old Red been sitting undriven. Check the old girl over and went to fire her up and nothing, battery was flat. Not surprising it is the original battery. So i threw a charger on it and the next day went out and she fired up. Running rough, A/F ratio all over the place. It settled down a little and I drove her to town a couple of times and the A/F was still wandering some, slow to track. Occassionally throwing low MAP signal. Put the MAP sensor and a few more items on order, This morning I'm pushing trying to get a few things done early and jump in and she won;t crank, hit the horn and it sounded weak. All the lights came on, but starter won't crank. Damn battery finally died. Went to town got a new battery and installed it. Jumped in and it won't crank. Double checked my starter cutout switch and notice the gear lever is in Reverse. So the lesson is if you are using a floor shifter make damn sure you put the sucker in PARK or it won't start. Checked the old battery and it read 12.68 vdc. I'm a DUMMY...

__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2012, 10:34 AM   #2
Greg
 
Redtruck-VA's Avatar
 
Join Date: Jan 2011
Location: Virginia
Posts: 18,929
Garage
Just got back from overseas and old Red been sitting undriven. Check the old girl over and went to fire her up and nothing, battery was flat. Not surprising it is the original battery. So i threw a charger on it and the next day went out and she fired up. Running rough, A/F ratio all over the place. It settled down a little and I drove her to town a couple of times and the A/F was still wandering some, slow to track. Occassionally throwing low MAP signal. Put the MAP sensor and a few more items on order, This morning I'm pushing trying to get a few things done early and jump in and she won;t crank, hit the horn and it sounded weak. All the lights came on, but starter won't crank. Damn battery finally died. Went to town got a new battery and installed it. Jumped in and it won't crank. Double checked my starter cutout switch and notice the gear lever is in Reverse. So the lesson is if you are using a floor shifter make damn sure you put the sucker in PARK or it won't start. Checked the old battery and it read 12.68 vdc. I'm a DUMMY...
__________________
2003 RCSB, 2wd, "Pro-Street"
6.4L/cog driven V7-Ysi/46rh trans/HTH Truckarm coilover suspension. HP Tuning...

1# 2017 HTC FASTEST HEMI List....
Current 1/4 mile [email protected] (2018)
Current 60' PB 1.351 (2019) mechanical issue for 1/4m

HTC 2018 TOTY

Support vehicle- 2007 QC G56 4x4 diesel
Redtruck-VA is online now   Reply With Quote
Old 03-21-2012, 11:22 AM   #3
Board of Directors-Bill
 
arocketman's Avatar
 
Join Date: Aug 2007
Location: Space Coast, FL/Eastern Shore, Va
Posts: 12,477
Garage
__________________
05 QC
BLUE MAX
"Slightly Tweaked"
Just [email protected]




arocketman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2012, 11:24 AM   #4
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
Chit happens.
__________________
2003, Std. SWB, SLT, 20", 4:56 gear, AFE CAI, Superchip, 6.1 cam, 6.1 heads, Manley springs, retainers, pushrods, Edelbrock Hedders, 195 T-Stat, 8.2 Taylor, AEM, Power Wire, ARC-1,Amsoil Everything, and more. Veni Vidi Vici

HTC.com Titan Killer Club

Member # 17



Superjay is offline   Reply With Quote
Old 03-21-2012, 01:14 PM   #5
Senior Member
 
nopeitsherhemi's Avatar
 
Join Date: Jul 2005
Location: Kalliesworld, Indiana
Posts: 13,314
Garage
thanks for sharing.
we all do things like that from time to time, most don't have the B#@%s to say anything, but it could help the next person who has a "blonde" moment..

that's almost as good as when my sister started the car back when she was 16 and forgot it was a clutch..
mom did not like that large concrete planter anyhow
__________________
tribuo nos pacis in terra
"WE LIVE IN THE LAND OF THE FREE, ONLY BECAUSE OF THE BRAVE"

2013 Ram 1500 SLT Crew Cab 4x4 Big Horn True Blue Pearl, Amsoil, Re-trax, Bedrug
2003 4x4 LB QC CAI, SC, Amsoil, Shorties, LED tails. GONE but never forgotten.





Member # 1450
nopeitsherhemi is offline   Reply With Quote
Old 03-21-2012, 01:16 PM   #6
tui
Senior Member
 
tui's Avatar
 
Join Date: Nov 2010
Location: New Zealand
Posts: 767
Garage
been doing dumb stuff all my life and dont think I'll change anytime soon.
tui is offline   Reply With Quote
Old 03-21-2012, 01:27 PM   #7
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
__________________
2003 Ram 5.7 HEMI RC 2WD - Supercharged. 520 HP, 14 mpg... SOLD
2006 SRT8 GC AWD 6.1 HEMI - 420 HP, 16 mpg... SOLD
2005 Ram 5.7 HEMI QC 4X4 - bone stock work truck... SOLD
2009 Ram 5.7 HEMI QC 4X4 Laramie - bone stock for now

MrHemi is offline   Reply With Quote
Old 03-21-2012, 01:41 PM   #8
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
Quote:
Originally posted by tui:
been doing dumb stuff all my life and dont think I'll change anytime soon.
I'm with you Mark. Some things never change.
Don't worry about it Greg. It only gets worse.
__________________

RANCHER is offline   Reply With Quote
Old 03-21-2012, 01:57 PM   #9
Senior Member
 
dr.dred's Avatar
 
Join Date: Apr 2005
Location: Saskatoon
Posts: 5,981
Wife's old Equinox!! POS> passenger window would not roll up. It would power down and then nothing. Took dor apart and had to pull the motor apart to pull up the window. It was winter guys!! Ordered new motor for the tune of almost $300! Special order to boot. Put the door and window all back together and WTF!! Window would go down but not up! !There was a penny stuck in the window switch!!! I hear ya brother!!
__________________


dr.dred is offline   Reply With Quote
Old 03-21-2012, 02:23 PM   #10
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
Similar story, but with a PC:

I had built this voice mail system (back in the day when NOTHING was on the motherboard). Could not get the dang thing to start! Got the boss to look at it (between the two of us we'd built probably 100 voice mail systems). We changed the video board, the I/O board, the memory, the HDD, etc., etc.

We were both standing there, scratching our heads when the new guy (been there less than a month) said, "Is it supposed to be set at 220V?"
__________________
MikeHTally is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.