Help-Security Indicator Light blinking - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 02-19-2012, 09:06 AM   #1
Senior Member
 
Big Daddy's Avatar
 
Join Date: Feb 2007
Location: Burlington, NC
Posts: 288
Got in truck this morning and turn the key. Everything usual came on for a split second then everything went off. The engine turned over for a split second also. Everything went dark no lights anywhere not even above with the door open. The only thing was a red blinking light in the lower right hand of the dash cluster which is the "Security Indicator" light. Can anyone help me so I can get my Ram back?

__________________
Big Daddy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-2012, 09:06 AM   #2
Senior Member
 
Big Daddy's Avatar
 
Join Date: Feb 2007
Location: Burlington, NC
Posts: 288
Got in truck this morning and turn the key. Everything usual came on for a split second then everything went off. The engine turned over for a split second also. Everything went dark no lights anywhere not even above with the door open. The only thing was a red blinking light in the lower right hand of the dash cluster which is the "Security Indicator" light. Can anyone help me so I can get my Ram back?
__________________
Big Daddy is offline   Reply With Quote
Old 02-19-2012, 10:08 AM   #3
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
Sounds like the security system doesn't like the key. Did you try the other key?
__________________
MikeHTally is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-2012, 10:13 AM   #4
Senior Member
 
Big Daddy's Avatar
 
Join Date: Feb 2007
Location: Burlington, NC
Posts: 288
Haven't tried another key yet. I am getting a new battery because read other places to disconnect battery and touch the two cables to discharge and reset the system, didn't work. Another post said battery may not have enough charge. I don't know how old the battery is and remember the other day it strained a little when cranking. I will try another key if the battery doesn't work.
__________________
Big Daddy is offline   Reply With Quote
Old 02-19-2012, 11:49 AM   #5
Senior Member
 
Big Daddy's Avatar
 
Join Date: Feb 2007
Location: Burlington, NC
Posts: 288
replaced the battery and it cranked. Taking it down the road for a test drive be back soon.
__________________
Big Daddy is offline   Reply With Quote
Old 02-19-2012, 01:25 PM   #6
Senior Member
 
Big Daddy's Avatar
 
Join Date: Feb 2007
Location: Burlington, NC
Posts: 288
everything good now, running as good as ever.
__________________
Big Daddy is offline   Reply With Quote
Old 02-19-2012, 02:33 PM   #7
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
__________________
2003 Ram 5.7 HEMI RC 2WD - Supercharged. 520 HP, 14 mpg... SOLD
2006 SRT8 GC AWD 6.1 HEMI - 420 HP, 16 mpg... SOLD
2005 Ram 5.7 HEMI QC 4X4 - bone stock work truck... SOLD
2009 Ram 5.7 HEMI QC 4X4 Laramie - bone stock for now

MrHemi is offline   Reply With Quote
Old 02-19-2012, 04:04 PM   #8
"Bob"
 
motorscooter's Avatar
 
Join Date: Nov 2005
Location: Tucson, AZ
Posts: 13,530
Garage
__________________
http://www.hemitruckclub.com/forums/...cture421t.jpeg
motorscooter is offline   Reply With Quote
Old 02-20-2012, 04:04 PM   #9
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
Quote:
Originally posted by Big Daddy:
... I am getting a new battery because read other places to disconnect battery and touch the two cables to discharge and reset the system, didn't work...
The reason that didn't work is you weren't holding your left earlobe in your right hand, right earlobe in your left hand while dancing on your left foot and bowing to the Hemi gods.
__________________
MikeHTally is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.