having some bad luck this month!!!! - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 09-23-2011, 10:35 PM   #1
Member
 
Join Date: Nov 2005
Location: Cornelius, NC
Posts: 51
hey guys so my water pump went out at the beginning of this month and i changed it myself. everything was fine but on my way home from dropping off the core part to get my refund the radiator cracked on me. i ordered a new one and replaced it and had no problem. then this last week the water pump went out again so i was replacing it and i broke a bolt. long story short i fixed it and its running fine but now i hear water running from inside the truck. there isnt any leaks or water lost but i know i here it what is it?

Surge! is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-23-2011, 10:35 PM   #2
Member
 
Join Date: Nov 2005
Location: Cornelius, NC
Posts: 51
hey guys so my water pump went out at the beginning of this month and i changed it myself. everything was fine but on my way home from dropping off the core part to get my refund the radiator cracked on me. i ordered a new one and replaced it and had no problem. then this last week the water pump went out again so i was replacing it and i broke a bolt. long story short i fixed it and its running fine but now i hear water running from inside the truck. there isnt any leaks or water lost but i know i here it what is it?
Surge! is offline   Reply With Quote
Old 09-24-2011, 04:17 AM   #3
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
Check your heater core. Sorry for the bad run of luck. Sounds like you had some bad anti-freeze or something.
__________________

RANCHER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2011, 05:22 AM   #4
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,427
air pocket in the core.park at a angle with the nose up. the air will go to the high point remove your cap also so the air can get out.it did the same to mine thats how i got it out.also wiggle around the heater hoses so the trapped air can move
__________________
boedacres is offline   Reply With Quote
Old 09-25-2011, 10:30 AM   #5
Mopower or no Power!!
 
3rd Strike Performance's Avatar
 
Join Date: May 2010
Location: Sikeston, MO
Posts: 2,221
what boedacres said. I think I would be replacing all the hoses too, if that hasn't been done, including the heater hose...
__________________
http://www.3rdstrikeperformance.com
Like us on Facebook!

Phone: 573-258-9999

[email protected]
3rd Strike Performance is offline   Reply With Quote
Old 09-25-2011, 01:20 PM   #6
Board of Directors-Bill
 
arocketman's Avatar
 
Join Date: Aug 2007
Location: Space Coast, FL/Eastern Shore, Va
Posts: 12,477
Garage
Bummer man.

Take the radiator cap off and run the motor to temp. Burp the hose by squeezing the hose to the thermostat in and out. Check the water level and cap it for some more squeezing. Repeat as required to get the air out.

__________________
05 QC
BLUE MAX
"Slightly Tweaked"
Just [email protected]




arocketman is offline   Reply With Quote
Old 09-26-2011, 05:54 AM   #7
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
__________________
2003, Std. SWB, SLT, 20", 4:56 gear, AFE CAI, Superchip, 6.1 cam, 6.1 heads, Manley springs, retainers, pushrods, Edelbrock Hedders, 195 T-Stat, 8.2 Taylor, AEM, Power Wire, ARC-1,Amsoil Everything, and more. Veni Vidi Vici

HTC.com Titan Killer Club

Member # 17



Superjay is offline   Reply With Quote
Old 09-26-2011, 07:11 AM   #8
Senior Member
 
ArcticWolf's Avatar
 
Join Date: Aug 2006
Location: Castro Valley, CA
Posts: 4,159
I agree with what Duane said...

He should know, he should be made our official Been There Done That man for just about anything that can go wrong...
__________________
......... Yea.. that California Old Fart has RETURNED!!!





ArcticWolf is offline   Reply With Quote
Old 09-27-2011, 07:05 PM   #9
Mopower or no Power!!
 
3rd Strike Performance's Avatar
 
Join Date: May 2010
Location: Sikeston, MO
Posts: 2,221
Quote:
Originally posted by ArcticWolf:
I agree with what Duane said...

He should know, he should be made our official Been There Done That man for just about anything that can go wrong...
Lol. Thanks buddy....yea, I have had things go wrong I never thought I would ever have to think about...but that's what happens when you drive a lot!
__________________
http://www.3rdstrikeperformance.com
Like us on Facebook!

Phone: 573-258-9999

[email protected]
3rd Strike Performance is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:48 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.